summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a20fe3c5d0c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = modenv-bin
+ pkgdesc = CLI to easily manage .env files and keep them consistent
+ pkgver = 0.10.3
+ pkgrel = 1
+ url = https://github.com/kurtbuilds/modenv
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ makedepends = help2man
+ provides = modenv
+ conflicts = modenv
+ source = LICENSE-0.10.3::https://raw.githubusercontent.com/kurtbuilds/modenv/v0.10.3/LICENSE.md
+ source = README-0.10.3::https://raw.githubusercontent.com/kurtbuilds/modenv/v0.10.3/README.md
+ sha256sums = 0fba33e712b47fff4ac42c8ffe9862a045b62b496c3843b781cda79d1714aa51
+ sha256sums = 7b28ae776caeec6ebfcb8345603a79dd321d43813db2c3b8159b70d7f083ae62
+ source_x86_64 = modenv-0.10.3.tar.gz::https://github.com/kurtbuilds/modenv/releases/download/v0.10.3/modenv-v0.10.3-x86_64-unknown-linux-musl.tar.gz
+ sha256sums_x86_64 = 1ea73688ce14deae89492460956324df6a73abf25520b31a688cdd4aa131e618
+ source_aarch64 = modenv-0.10.3.tar.gz::https://github.com/kurtbuilds/modenv/releases/download/v0.10.3/modenv-v0.10.3-aarch64-unknown-linux-musl.tar.gz
+ sha256sums_aarch64 = 1ea73688ce14deae89492460956324df6a73abf25520b31a688cdd4aa131e618
+
+pkgname = modenv-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13e013d0b038
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Rafael Dominiquini <rafaeldominiquini at gmail dor com>
+
+_pkgauthor=kurtbuilds
+_pkgname=modenv
+pkgname=${_pkgname}-bin
+pkgver=0.10.3
+pkgrel=1
+pkgdesc="CLI to easily manage .env files and keep them consistent"
+arch=('x86_64' 'aarch64')
+url="https://github.com/${_pkgauthor}/${_pkgname}"
+_urlraw="https://raw.githubusercontent.com/${_pkgauthor}/${_pkgname}/v${pkgver}"
+license=('MIT')
+
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+makedepends=('help2man')
+
+source=("LICENSE-${pkgver}::${_urlraw}/LICENSE.md"
+ "README-${pkgver}::${_urlraw}/README.md")
+source_x86_64=("${_pkgname}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}-v${pkgver}-${arch[0]}-unknown-linux-musl.tar.gz")
+source_aarch64=("${_pkgname}-${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}-v${pkgver}-${arch[1]}-unknown-linux-musl.tar.gz")
+sha256sums=('0fba33e712b47fff4ac42c8ffe9862a045b62b496c3843b781cda79d1714aa51'
+ '7b28ae776caeec6ebfcb8345603a79dd321d43813db2c3b8159b70d7f083ae62')
+sha256sums_x86_64=('1ea73688ce14deae89492460956324df6a73abf25520b31a688cdd4aa131e618')
+sha256sums_aarch64=('1ea73688ce14deae89492460956324df6a73abf25520b31a688cdd4aa131e618')
+
+
+build() {
+ cd "${srcdir}/" || exit
+
+ help2man "./${_pkgname}" --output "MAN-${pkgver}.1" --no-info
+
+ gzip "MAN-${pkgver}.1"
+}
+
+package() {
+ cd "${srcdir}/" || exit
+
+ install -Dm755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+
+ install -Dm644 "LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+
+ install -Dm644 "README-${pkgver}" "$pkgdir/usr/share/doc/$pkgname/README.md"
+
+ install -Dm644 "MAN-${pkgver}.1.gz" "${pkgdir}/usr/share/man/man1/${_pkgname}.1.gz"
+}