summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0953501ac7d..7cc5cc2dbf02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = modrinth-app
pkgdesc = An unique, open source launcher that allows you to play your favorite mods, and keep them up to date, all in one neat little package.
pkgver = 0.7.1
- pkgrel = 1
+ pkgrel = 3
url = https://modrinth.com/app
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index aed2ef9f2e6e..fac56d75b7af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=modrinth-app
pkgver=0.7.1
-pkgrel=1
+pkgrel=3
pkgdesc='An unique, open source launcher that allows you to play your favorite mods, and keep them up to date, all in one neat little package.'
url='https://modrinth.com/app'
arch=('x86_64')
@@ -30,20 +30,24 @@ options=('!lto')
prepare() {
cd "theseus-${pkgver}"
+ export CARGO_TARGET_DIR=target
export RUSTUP_TOOLCHAIN=stable
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
cd "theseus_gui"
- pnpm install --frozen-lockfile
+ export COREPACK_ENABLE_STRICT=0
+ pnpm install
}
build() {
cd "theseus-${pkgver}/theseus_gui/"
+ export COREPACK_ENABLE_STRICT=0
pnpm build
cd ..
+ export CARGO_TARGET_DIR=target
export RUSTUP_TOOLCHAIN=stable
cargo build --frozen --release --all-features
}
@@ -51,6 +55,7 @@ build() {
check() {
cd "theseus-${pkgver}"
+ export CARGO_TARGET_DIR=target
export RUSTUP_TOOLCHAIN=stable
cargo test --frozen --all-features
}