summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--cmake-wallet.patch77
3 files changed, 93 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6dd65b731430..8f61c193723e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Oct 30 13:28:08 UTC 2017
+# Wed Nov 8 00:49:47 UTC 2017
pkgbase = monero
pkgdesc = Monero: the secure, private, untraceable currency - release version (includes daemon, wallet and miner)
pkgver = 0.11.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://getmonero.org/
arch = x86_64
arch = i686
@@ -25,8 +25,10 @@ pkgbase = monero
conflicts = libmonero-wallet-git
source = https://github.com/monero-project/monero/archive/v0.11.1.0.tar.gz
source = monerod.service
+ source = cmake-wallet.patch
sha256sums = b5b48d3e5317c599e1499278580e9a6ba3afc3536f4064fcf7b20840066a509b
sha256sums = 59fc670cf92960832d03038968270f81beacea7d6819c71ec5bcf15c6030e3c9
+ sha256sums = 50cee20da90c920762c464beebaf550a70548ad942c35f5632fa37706ccf9b23
pkgname = monero
install = monero.install
diff --git a/PKGBUILD b/PKGBUILD
index 612189f58c54..010a8b2e816d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgbase=('monero')
pkgname=('monero' 'libmonero-wallet')
pkgver=0.11.1.0
-pkgrel=2
+pkgrel=3
pkgdesc="Monero: the secure, private, untraceable currency - release version (includes daemon, wallet and miner)"
license=('custom:Cryptonote')
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
@@ -16,14 +16,22 @@ provides=('monero' 'libmonero-wallet')
conflicts=('bitmonero-git' 'libmonero-wallet-git')
source=("https://github.com/monero-project/monero/archive/v${pkgver}.tar.gz"
- "monerod.service")
+ "monerod.service"
+ "cmake-wallet.patch")
sha256sums+=('b5b48d3e5317c599e1499278580e9a6ba3afc3536f4064fcf7b20840066a509b'
- '59fc670cf92960832d03038968270f81beacea7d6819c71ec5bcf15c6030e3c9')
+ '59fc670cf92960832d03038968270f81beacea7d6819c71ec5bcf15c6030e3c9'
+ '50cee20da90c920762c464beebaf550a70548ad942c35f5632fa37706ccf9b23')
_monero="${pkgbase}-${pkgver}"
_build=build
+prepare()
+{
+ cd "${srcdir}/${_monero}"
+ patch -Np1 -i "${srcdir}/cmake-wallet.patch"
+}
+
build() {
cd "${srcdir}/${_monero}"
CMAKE_FLAGS+=" -DCMAKE_BUILD_TYPE=Release "
@@ -60,6 +68,7 @@ package_monero() {
install -Dm755 "${srcdir}/${_monero}/build/bin/monero-blockchain-export" "${pkgdir}/usr/bin/monero-blockchain-export"
install -Dm755 "${srcdir}/${_monero}/build/bin/monero-blockchain-import" "${pkgdir}/usr/bin/monero-blockchain-import"
install -Dm755 "${srcdir}/${_monero}/build/bin/monero-wallet-cli" "${pkgdir}/usr/bin/monero-wallet-cli"
+ install -Dm755 "${srcdir}/${_monero}/build/bin/monero-wallet-rpc" "${pkgdir}/usr/bin/monero-wallet-rpc"
install -Dm755 "${srcdir}/${_monero}/build/bin/monerod" "${pkgdir}/usr/bin/monerod"
install -Dm644 "${srcdir}/${_monero}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
diff --git a/cmake-wallet.patch b/cmake-wallet.patch
new file mode 100644
index 000000000000..434afac01583
--- /dev/null
+++ b/cmake-wallet.patch
@@ -0,0 +1,77 @@
+diff --git a/src/wallet/CMakeLists.txt b/src/wallet/CMakeLists.txt
+index 63908005..16230545 100644
+--- a/src/wallet/CMakeLists.txt
++++ b/src/wallet/CMakeLists.txt
+@@ -86,42 +86,40 @@ target_link_libraries(wallet
+ ${EXTRA_LIBRARIES})
+ add_dependencies(wallet version)
+
+-if (NOT BUILD_GUI_DEPS)
+- set(wallet_rpc_sources
+- wallet_rpc_server.cpp)
++set(wallet_rpc_sources
++ wallet_rpc_server.cpp)
+
+- set(wallet_rpc_headers)
++set(wallet_rpc_headers)
+
+- set(wallet_rpc_private_headers
+- wallet_rpc_server.h)
++set(wallet_rpc_private_headers
++ wallet_rpc_server.h)
+
+- monero_private_headers(wallet_rpc_server
+- ${wallet_rpc_private_headers})
+- monero_add_executable(wallet_rpc_server
+- ${wallet_rpc_sources}
+- ${wallet_rpc_headers}
+- ${wallet_rpc_private_headers})
++monero_private_headers(wallet_rpc_server
++ ${wallet_rpc_private_headers})
++monero_add_executable(wallet_rpc_server
++ ${wallet_rpc_sources}
++ ${wallet_rpc_headers}
++ ${wallet_rpc_private_headers})
+
+- target_link_libraries(wallet_rpc_server
+- PRIVATE
+- wallet
+- epee
+- rpc
+- cryptonote_core
+- cncrypto
+- common
+- ${Boost_CHRONO_LIBRARY}
+- ${Boost_PROGRAM_OPTIONS_LIBRARY}
+- ${Boost_FILESYSTEM_LIBRARY}
+- ${Boost_THREAD_LIBRARY}
+- ${CMAKE_THREAD_LIBS_INIT}
+- ${EXTRA_LIBRARIES})
+- add_dependencies(wallet_rpc_server version)
+- set_property(TARGET wallet_rpc_server
+- PROPERTY
+- OUTPUT_NAME "monero-wallet-rpc")
+- install(TARGETS wallet_rpc_server DESTINATION bin)
+-endif()
++target_link_libraries(wallet_rpc_server
++ PRIVATE
++ wallet
++ epee
++ rpc
++ cryptonote_core
++ cncrypto
++ common
++ ${Boost_CHRONO_LIBRARY}
++ ${Boost_PROGRAM_OPTIONS_LIBRARY}
++ ${Boost_FILESYSTEM_LIBRARY}
++ ${Boost_THREAD_LIBRARY}
++ ${CMAKE_THREAD_LIBS_INIT}
++ ${EXTRA_LIBRARIES})
++add_dependencies(wallet_rpc_server version)
++set_property(TARGET wallet_rpc_server
++ PROPERTY
++ OUTPUT_NAME "monero-wallet-rpc")
++install(TARGETS wallet_rpc_server DESTINATION bin)
+
+
+ # build and install libwallet_merged only if we building for GUI