summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD16
1 files changed, 15 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 114a633bb4fd..82bf480beea1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,7 +25,8 @@ makedepends=('git' 'cmake' 'boost' 'gtest')
pkgdesc="Peer-to-peer anonymous digital currency (daemon, CLI wallet, and wallet API library)"
-source=("$_gitname::git+https://github.com/monero-project/monero.git")
+_upstream=https://github.com/monero-project/monero.git
+source=("$_gitname::git+$_upstream")
md5sums=('SKIP')
@@ -41,6 +42,19 @@ pkgver() {
"$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/$_gitname"
+
+ git remote add up $_upstream
+
+ if check_option "debug" "y"
+ then
+ git pull --no-edit up refs/pull/2645/head # cmake install path fix
+ fi
+
+ git pull --no-edit up refs/pull/2663/head # fix for openssl v1.1
+}
+
build() {
cd "$srcdir/$_gitname"