summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD23
-rw-r--r--mongodb-4.4.29-no-enterprise.patch24
4 files changed, 44 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25267d647b79..f75d30b64256 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mongodb
pkgdesc = A high-performance, open source, schema-free document-oriented database
- pkgver = 7.0.8
+ pkgver = 7.0.11
pkgrel = 1
url = https://www.mongodb.com/
arch = x86_64
@@ -33,21 +33,23 @@ pkgbase = mongodb
depends = krb5
optdepends = mongodb-tools: mongoimport, mongodump, mongotop, etc
optdepends = mongosh: interactive shell to connect with MongoDB
- provides = mongodb=7.0.8
+ provides = mongodb=7.0.11
options = !debug
backup = etc/mongodb.conf
- source = https://fastdl.mongodb.org/src/mongodb-src-r7.0.8.tar.gz
+ source = https://github.com/mongodb/mongo/archive/refs/tags/r7.0.11.tar.gz
source = mongodb.sysusers
source = mongodb.tmpfiles
source = mongodb-5.0.2-skip-reqs-check.patch
source = mongodb-5.0.2-no-compass.patch
source = mongodb-7.0.2-sconstruct.patch
- sha256sums = 9bfb291379bde902a9c35ee30455a335381fec4836f59f3ef399eeef07501412
+ source = mongodb-4.4.29-no-enterprise.patch
+ sha256sums = 3138a4cfae5efdf5f36daeeb51c54d988f3e633834fcbf1f672803896203640b
sha256sums = 3757d548cfb0e697f59b9104f39a344bb3d15f802608085f838cb2495c065795
sha256sums = b7d18726225cd447e353007f896ff7e4cbedb2f641077bce70ab9d292e8f8d39
sha256sums = 4ff40320e04bf8c3e05cbc662f8ea549a6b8494d1fda64b1de190c88587bfafd
sha256sums = 41b75d19ed7c4671225f08589e317295b7abee934b876859c8777916272f3052
sha256sums = 078d94d712c3bb86a77d13bf2021299f4db2332c9d5346dba1ceb0cce1ba8492
+ sha256sums = 7cd27b2ce15cc6efdce07ef934ed3d9356025ebade4856a9d0a75a80f7c08905
source_aarch64 = extrapatch-sconstruct.patch
sha256sums_aarch64 = 6dd9f20e153ff2a3e185d9411e9d9ec54ba8ed29a0a1489828ccb047205cceac
diff --git a/.gitignore b/.gitignore
index 5cedbff857dc..f6819c0d3314 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,7 @@
mongodb-*.pkg.tar.zst
mongodb-src-*.tar.gz
mongodb-*.log
+*.tar.*
PKGBUILD-namcap.log
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index 2acc963c2dd2..4ae9b4d5e27b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# shellcheck disable=SC2034,SC2154,SC2164
# Maintainer: JustKidding <jk@vin.ovh>
-# Maintainer: James P. Harvey <jamespharvey20 at gmail dot com>
-# Maintainer: Christoph Bayer <chrbayer@criby.de>
+# Contributor: James P. Harvey <jamespharvey20 at gmail dot com>
+# Contributor: Christoph Bayer <chrbayer@criby.de>
# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: Thomas Dziedzic < gostrc at gmail >
@@ -13,7 +13,7 @@
pkgname=mongodb
_pkgname=mongodb
# #.<odd number>.# releases are unstable development/testing
-pkgver=7.0.8
+pkgver=7.0.11
pkgrel=1
pkgdesc="A high-performance, open source, schema-free document-oriented database"
arch=("x86_64" "aarch64")
@@ -28,18 +28,20 @@ optdepends=('mongodb-tools: mongoimport, mongodump, mongotop, etc'
backup=("etc/mongodb.conf")
provides=(mongodb="$pkgver")
options=(!debug)
-source=("https://fastdl.mongodb.org/src/mongodb-src-r$pkgver.tar.gz"
+source=("https://github.com/mongodb/mongo/archive/refs/tags/r$pkgver.tar.gz"
mongodb.sysusers
mongodb.tmpfiles
mongodb-5.0.2-skip-reqs-check.patch
mongodb-5.0.2-no-compass.patch
- mongodb-7.0.2-sconstruct.patch)
-sha256sums=('9bfb291379bde902a9c35ee30455a335381fec4836f59f3ef399eeef07501412'
+ mongodb-7.0.2-sconstruct.patch
+ mongodb-4.4.29-no-enterprise.patch)
+sha256sums=('3138a4cfae5efdf5f36daeeb51c54d988f3e633834fcbf1f672803896203640b'
'3757d548cfb0e697f59b9104f39a344bb3d15f802608085f838cb2495c065795'
'b7d18726225cd447e353007f896ff7e4cbedb2f641077bce70ab9d292e8f8d39'
'4ff40320e04bf8c3e05cbc662f8ea549a6b8494d1fda64b1de190c88587bfafd'
'41b75d19ed7c4671225f08589e317295b7abee934b876859c8777916272f3052'
- '078d94d712c3bb86a77d13bf2021299f4db2332c9d5346dba1ceb0cce1ba8492')
+ '078d94d712c3bb86a77d13bf2021299f4db2332c9d5346dba1ceb0cce1ba8492'
+ '7cd27b2ce15cc6efdce07ef934ed3d9356025ebade4856a9d0a75a80f7c08905')
sha256sums_aarch64=('6dd9f20e153ff2a3e185d9411e9d9ec54ba8ed29a0a1489828ccb047205cceac')
source_aarch64=(extrapatch-sconstruct.patch)
@@ -48,6 +50,7 @@ _scons_args=(
CXX="${CXX:-g++}"
AR="${AR:-ar}"
MONGO_DISTMOD=arch
+ MONGO_VERSION="$pkgver"
--use-system-boost
--use-system-pcre2
@@ -94,7 +97,7 @@ filter-flags() {
}
prepare() {
- cd "${srcdir}/${_pkgname}-src-r${pkgver}"
+ cd "${srcdir}/mongo-r${pkgver}"
# Keep historical Arch dbPath
sed -i 's|dbPath: /var/lib/mongo|dbPath: /var/lib/mongodb|' rpm/mongod.conf
@@ -131,7 +134,7 @@ prepare() {
}
build() {
- cd "${srcdir}/${_pkgname}-src-r${pkgver}"
+ cd "${srcdir}/mongo-r${pkgver}"
if check_option debug n; then
filter-flags '-m*'
@@ -143,7 +146,7 @@ build() {
}
package() {
- cd "${srcdir}/${_pkgname}-src-r${pkgver}"
+ cd "${srcdir}/mongo-r${pkgver}"
# Install binaries
install -D build/install/bin/mongo "$pkgdir/usr/bin/mongo"
diff --git a/mongodb-4.4.29-no-enterprise.patch b/mongodb-4.4.29-no-enterprise.patch
new file mode 100644
index 000000000000..bbcbe34fe6f3
--- /dev/null
+++ b/mongodb-4.4.29-no-enterprise.patch
@@ -0,0 +1,24 @@
+ buildscripts/moduleconfig.py | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/buildscripts/moduleconfig.py b/buildscripts/moduleconfig.py
+index b4d0bba0490..03541fab940 100644
+--- a/buildscripts/moduleconfig.py
++++ b/buildscripts/moduleconfig.py
+@@ -27,7 +27,6 @@ MongoDB SConscript files do.
+ __all__ = ('discover_modules', 'discover_module_directories', 'configure_modules',
+ 'register_module_test') # pylint: disable=undefined-all-variable
+
+-import imp
+ import inspect
+ import os
+
+@@ -71,8 +70,6 @@ def discover_modules(module_root, allowed_modules):
+ print("adding module: %s" % (name))
+ fp = open(build_py, "r")
+ try:
+- module = imp.load_module("module_" + name, fp, build_py,
+- (".py", "r", imp.PY_SOURCE))
+ if getattr(module, "name", None) is None:
+ module.name = name
+ found_modules.append(module)