summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ee08c792db4..757733b4e8c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = monkeyjump
pkgdesc = Minimalistic GUI for playing Go with GnuGo and other GTP applications
pkgver = 0.5
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/xyproto/monkeyjump
arch = any
license = GPL2
makedepends = gendesk
makedepends = setconf
- depends = pypy
+ depends = python2-pygame
depends = gnugo
backup = etc/monkeyjump/gnugocmd.conf
backup = etc/monkeyjump/theme.conf
diff --git a/PKGBUILD b/PKGBUILD
index 61c6fcfac57d..b80149880aa7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=monkeyjump
pkgver=0.5
-pkgrel=4
+pkgrel=5
pkgdesc='Minimalistic GUI for playing Go with GnuGo and other GTP applications'
arch=(any)
url='https://github.com/xyproto/monkeyjump'
license=(GPL2)
-depends=(pypy gnugo)
+depends=(python2-pygame gnugo)
makedepends=(gendesk setconf)
backup=(etc/monkeyjump/gnugocmd.conf etc/monkeyjump/theme.conf etc/monkeyjump/keybindings.conf)
source=("git+$url#commit=a6fcea4e0f03c09a47b0117567893d0fe882b2a8")
@@ -24,13 +24,12 @@ prepare() {
--terminal=true
setconf monkeyjump CONFDIR=\"/etc/monkeyjump\"
setconf monkeyjump THEMEDIR=\"/usr/share/monkeyjump/themes\"
- sed -i 's/env python2/env pypy/g' $pkgname
}
package() {
cd "$pkgname"
- pypy setup.py install --root="$pkgdir" --optimize=1
+ python2 setup.py install --root="$pkgdir" --optimize=1
# Executable
install -Dm755 monkeyjump "$pkgdir/usr/bin/monkeyjump"