summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD46
-rw-r--r--monotone.install29
3 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c82989b3d06
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = monotone-snapshot
+ pkgdesc = A modern distributed version control system, like hg, darcs, or git (dev snapshot)
+ pkgver = 1.2.dev
+ pkgrel = 1
+ url = https://code.monotone.ca/p/monotone
+ install = monotone.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ makedepends = git
+ depends = pcre
+ depends = lua
+ depends = botan
+ depends = sqlite3
+ depends = libidn
+ depends = zlib
+ provides = monotone
+ conflicts = monotone
+ source = monotone-snapshot::git+https://github.com/skydrome/monotone.vcs.mirror.git
+ sha256sums = SKIP
+
+pkgname = monotone-snapshot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4259e385231
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Angel Velasquez <angvp@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+# Contributor: Jeff 'codemac' Mickey <jeff@archlinux.org>
+# Contributor: Dan McGee <dpmcgee@gmail.com>
+
+pkgname=monotone-snapshot
+pkgver=1.2.dev
+pkgrel=1
+_snapshot=39626e94a960267e612c72c565b529674834b862
+pkgdesc='A modern distributed version control system, like hg, darcs, or git (dev snapshot)'
+arch=('i686' 'x86_64')
+url='https://code.monotone.ca/p/monotone'
+license=('GPL')
+depends=('pcre' 'lua' 'botan' 'sqlite3' 'libidn' 'zlib')
+makedepends=('boost' 'git')
+provides=('monotone')
+conflicts=('monotone')
+install=monotone.install
+source=($pkgname::"git+https://github.com/skydrome/monotone.vcs.mirror.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ sed -i "s/echo \"unknown\"/echo \"$_snapshot\"/" 'Makefile.am'
+ aclocal
+ autoreconf --install
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ export DISABLE_NETWORK_TESTS=1
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-nls
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" install
+ install -d "${pkgdir}/usr/share/vim/vimfiles/plugin/"
+ install -Dm644 contrib/monotone.zsh_completion "${pkgdir}/usr/share/zsh/site-functions/_mtn"
+ install -Dm644 contrib/{mtncommit,basicio}.vim "${pkgdir}/usr/share/vim/vimfiles/plugin/"
+}
diff --git a/monotone.install b/monotone.install
new file mode 100644
index 000000000000..298adb64a082
--- /dev/null
+++ b/monotone.install
@@ -0,0 +1,29 @@
+infodir=usr/share/info
+filelist=(monotone.info.gz)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+
+ # arg 1: the new package version
+ # arg 2: the old package version
+ if [[ "$(vercmp $2 0.45)" -lt 0 ]]; then
+ echo ">>> Your monotone databases will need updating for an internal format"
+ echo ">>> change. Please run the following command on each of your databases"
+ echo ">>> (after remembering to take a backup copy):"
+ echo ">>> $ mtn -d dbname.mtn db migrate"
+ fi
+}
+
+pre_remove() {
+ [[ -x usr/bin/install-info ]] || return 0
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}