summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a6f0b90c6fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = montagu-slab-font
+ pkgdesc = a slab-serif display typeface by Florian Karsten inspired by from 19th-century classic designs with weight and optical size axis
+ pkgver = 1.000
+ pkgrel = 1
+ url = https://github.com/floriankarsten/montagu-slab
+ arch = any
+ license = OFL
+ source = https://github.com/floriankarsten/montagu-slab/releases/download/1.0.0/MontaguSlab-1.0.0.zip
+ sha256sums = 10f5a002dda88518d7394aebcbb8a5f62d73c6bfeca517fab266ebc729bba5e4
+
+pkgname = otf-montagu-slab
+ provides = montagu-slab-font
+
+pkgname = ttf-montagu-slab
+ provides = montagu-slab-font
+
+pkgname = ttf-montagu-slab-variable
+ provides = montagu-slab-font
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6d54262cddb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_name=montagu-slab
+pkgbase=$_name-font
+pkgname=(otf-$_name ttf-$_name ttf-$_name-variable)
+pkgver=1.000
+_pkgver=1.0.0
+pkgrel=1
+pkgdesc='a slab-serif display typeface by Florian Karsten inspired by from 19th-century classic designs with weight and optical size axis'
+arch=(any)
+url="https://github.com/floriankarsten/$_name"
+license=(OFL)
+_archive="MontaguSlab-$_pkgver"
+source=("https://github.com/floriankarsten/montagu-slab/releases/download/$_pkgver/$_archive.zip")
+sha256sums=('10f5a002dda88518d7394aebcbb8a5f62d73c6bfeca517fab266ebc729bba5e4')
+
+package_otf-montagu-slab() {
+ cd "$_archive"
+ provides=("$pkgbase")
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" otf/*.otf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" OFL.txt
+}
+
+package_ttf-montagu-slab() {
+ cd "$_archive"
+ provides=("$pkgbase")
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" ttf/*.ttf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" OFL.txt
+}
+
+package_ttf-montagu-slab-variable() {
+ cd "$_archive"
+ provides=("$pkgbase")
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" ttf-variable/*.ttf
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" OFL.txt
+}