summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--moonfire-nvr-git.install8
3 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55c969dd53d2..7359f95da185 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = moonfire-nvr-git
pkgdesc = Security camera network video recorder
- pkgver = r302.35e6891
- pkgrel = 2
+ pkgver = r353.856c019
+ pkgrel = 1
url = https://github.com/scottlamb/moonfire-nvr
install = moonfire-nvr-git.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index a96d1f2111af..addb73473345 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=moonfire-nvr
pkgname=moonfire-nvr-git
-pkgver=r337.c271cfa
+pkgver=r350.81d4fd6
pkgrel=1
pkgdesc='Security camera network video recorder'
arch=('x86_64')
@@ -14,8 +14,7 @@ provides=("$_pkgname")
conflicts=("$_pkgname")
install=$pkgname.install
source=("git+$url.git"
- 'moonfire-nvr.service'
- 'moonfire-nvr.sysusers.conf')
+ 'moonfire-nvr'.{service,sysusers.conf})
sha512sums=('SKIP'
'b074b9902f4b7a4b0229b647f0a8268915c637d02157df43927d0a05335822ada256b54d0babdb2d429f80dc746015249ebce3a80ca8d3d4e7b70125b38c45c5'
'4e5be3c260bea782e2a4b226a1a375f97e9fd2e8ec0c1f4dc32176681b50db7fc17bacb77c5f2b8ae3d49f3d400ccbda3ad25dc32832e8042807e2d61fe3f15d')
@@ -29,7 +28,12 @@ build() {
cd $_pkgname
yarn
yarn build
- cargo build --release
+ cargo build --release --locked
+}
+
+check() {
+ cd $_pkgname
+ cargo test --release --locked
}
package() {
diff --git a/moonfire-nvr-git.install b/moonfire-nvr-git.install
index 18d05497e74e..07aa6386f5c5 100644
--- a/moonfire-nvr-git.install
+++ b/moonfire-nvr-git.install
@@ -2,14 +2,14 @@ post_install() {
cat << EOF
For fresh installs, follow these steps:
-Create the database and sample file directory:
-$ sudo install -d -g moonfire-nvr -o moonfire-nvr /var/lib/moonfire-nvr/{,db,sample}
+Install the database directory and initialize it:
+$ sudo install -dm700 -g moonfire-nvr -o moonfire-nvr /var/lib/moonfire-nvr/db
$ sudo -u moonfire-nvr moonfire-nvr init
-Configure the database:
+Configure Moonfire NVR:
$ sudo -u moonfire-nvr moonfire-nvr config 2>debug-log
-Start and enable the daemon:
+Enable and start the service:
$ sudo systemctl enable --now moonfire-nvr
Access the WebUI at <http://localhost:8080>.