summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
-rw-r--r--android-fix.patch16
3 files changed, 32 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 452b6e16048f..5a6b9e82db00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mozc-ut-united
pkgdesc = A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input)
- pkgver = 2.26.4610.102.20220112
+ pkgver = 2.26.4610.102_20220112_2018.02.26.r231.g7329757e
pkgrel = 2
url = https://osdn.net/users/utuhiro/pf/utuhiro/files/
arch = i686
@@ -16,7 +16,7 @@ pkgbase = mozc-ut-united
makedepends = bazel
depends = qt5-base
depends = zinnia
- source = mozc::git+https://github.com/google/mozc.git#commit=c914d1dfe8b4193731b22da7ee3f53612a94269d
+ source = mozc::git+https://github.com/google/mozc.git
source = https://osdn.net/downloads/users/37/37585/mozcdic-ut-20220112.tar.bz2
source = config-arch-new.patch
source = git+https://chromium.googlesource.com/breakpad/breakpad
@@ -26,6 +26,8 @@ pkgbase = mozc-ut-united
source = git+https://github.com/open-source-parsers/jsoncpp.git
source = git+https://github.com/google/protobuf.git
source = git+https://github.com/abseil/abseil-cpp.git
+ source = android-fix.patch
+ sha1sums = SKIP
sha1sums = SKIP
sha1sums = SKIP
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6be377dc21c9..1864cda0c07e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ _bldtype=Release
# https://osdn.net/users/utuhiro/pf/utuhiro/files/
#*************************************************************
-_mozcrev=c914d1dfe8b4193731b22da7ee3f53612a94269d
+#_mozcrev=c914d1dfe8b4193731b22da7ee3f53612a94269d
_mozcver=2.26.4610.102
_utdicdate=20220112
_utdicver=1
@@ -31,15 +31,15 @@ _utdicver=1
pkgbase=mozc-ut-united
pkgname=mozc-ut-united
true && pkgname=('mozc-ut-united')
-pkgver=${_mozcver}.${_utdicdate}
+pkgver=2.26.4610.102_20220112_2018.02.26.r231.g7329757e
pkgrel=2
arch=('i686' 'x86_64')
url="https://code.google.com/p/mozc/"
url="https://osdn.net/users/utuhiro/pf/utuhiro/files/"
license=('BSD' 'GPL' 'custom')
makedepends=('ruby' 'git' 'ninja' 'clang' 'zinnia' 'bazel')
-source=("mozc::git+https://github.com/google/mozc.git#commit=${_mozcrev}" "https://osdn.net/downloads/users/37/37585/mozcdic-ut-${_utdicdate}.tar.bz2" "config-arch-new.patch" "git+https://chromium.googlesource.com/breakpad/breakpad" "git+https://github.com/google/googletest.git" "git+https://chromium.googlesource.com/external/gyp" "git+https://github.com/hiroyuki-komatsu/japanese-usage-dictionary.git" "git+https://github.com/open-source-parsers/jsoncpp.git" "git+https://github.com/google/protobuf.git" "git+https://github.com/abseil/abseil-cpp.git")
-sha1sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+source=("mozc::git+https://github.com/google/mozc.git" "https://osdn.net/downloads/users/37/37585/mozcdic-ut-${_utdicdate}.tar.bz2" "config-arch-new.patch" "git+https://chromium.googlesource.com/breakpad/breakpad" "git+https://github.com/google/googletest.git" "git+https://chromium.googlesource.com/external/gyp" "git+https://github.com/hiroyuki-komatsu/japanese-usage-dictionary.git" "git+https://github.com/open-source-parsers/jsoncpp.git" "git+https://github.com/google/protobuf.git" "git+https://github.com/abseil/abseil-cpp.git" "android-fix.patch")
+sha1sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
if [[ "$_emacs_mozc" == "yes" ]]; then
@@ -51,15 +51,19 @@ if [[ "$_ibus_mozc" == "yes" ]]; then
true && pkgname+=('ibus-mozc-ut-united')
fi
+pkgver() {
+ cd "${srcdir}/mozc/"
+
+ printf "%s_%s_%s" "${_mozcver}" "${_utdicdate}" "$(git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g')"
+}
+
prepare() {
# Enabling all dictionaries
sed -i '/^#.*="true"/ s/^#//' ${srcdir}/mozcdic-ut-${_utdicdate}/src/make-dictionaries.sh
mkdir -p mozc/src/third_party
-
cd "${srcdir}/mozc/"
-
git submodule init
git config submodule.breakpad.url "$srcdir/breakpad"
git config submodule.gtest.url "$srcdir/googletest"
@@ -75,6 +79,8 @@ prepare() {
#fixes file include locations for ibus, and gtk along with correcting qt location on arch
patch -d "${srcdir}/mozc/src" -i "${srcdir}/config-arch-new.patch"
+ patch -d "${srcdir}/mozc/src" -i "${srcdir}/android-fix.patch"
+
}
build() {
diff --git a/android-fix.patch b/android-fix.patch
new file mode 100644
index 000000000000..76e4717d0606
--- /dev/null
+++ b/android-fix.patch
@@ -0,0 +1,16 @@
+--- WORKSPACE.bazel 2022-01-31 15:44:11.510958782 -0500
++++ WORKSPACE-new.bazel 2022-01-31 15:48:42.861958776 -0500
+@@ -5,11 +5,11 @@
+ load("//:config.bzl", "QT_BASE_PATH")
+
+ # This rule reffers $ANDROID_SDK_HOME
+-android_sdk_repository(name = "androidsdk")
++#android_sdk_repository(name = "androidsdk")
+
+ # Android NDK version should be r11c+ for Abseil.
+ # This rule reffers $ANDROID_NDK_HOME
+-android_ndk_repository(name = "androidndk")
++#android_ndk_repository(name = "androidndk")
+
+ local_repository(
+ name = "com_google_absl",