summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore16
-rw-r--r--PKGBUILD48
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a371e4284b02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mpris-notifier-git
+ pkgdesc = Dependency-light, highly-customizable, XDG desktop notification generator for 🎢🎡 MPRIS status changes 🎹
+ pkgver = r41.a4ea1ca
+ pkgrel = 1
+ url = https://github.com/l1na-forever/mpris-notifier
+ arch = x86_64
+ license = unknown
+ makedepends = git
+ makedepends = cargo
+ provides = mpris-notifier
+ conflicts = mpris-notifier
+ source = mpris-notifier::git+https://github.com/l1na-forever/mpris-notifier
+ sha512sums = SKIP
+
+pkgname = mpris-notifier-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3c88e081244e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,16 @@
+mpris-notifier/
+
+# ---> ArchLinuxPackages
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25ff6cdc80fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: fossdd <fossdd@pwned.life>
+pkgname=mpris-notifier-git
+_pkgname=${pkgname%-git}
+pkgver=r41.a4ea1ca
+pkgrel=1
+pkgdesc='Dependency-light, highly-customizable, XDG desktop notification generator for 🎢🎡 MPRIS status changes 🎹'
+arch=('x86_64')
+url='https://github.com/l1na-forever/mpris-notifier'
+license=('unknown')
+depends=()
+makedepends=('git' 'cargo')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=(
+ "$_pkgname::git+$url"
+)
+sha512sums=(
+ 'SKIP'
+)
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_pkgname"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
+}
+
+build() {
+ cd "$_pkgname"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd "$_pkgname"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$_pkgname"
+}