summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
2 files changed, 13 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 361fb9622080..ec0f1f1f6000 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = mpsolve2
pkgdesc = Multiprecision rootfinder for complex roots of univariate polynomials (version 2)
pkgver = 2.2
- pkgrel = 1
- url = http://numpi.dm.unipi.it/software/mpsolve
+ pkgrel = 2
+ url = http://numpi.dm.unipi.it/mpsolve-2.2
arch = i686
arch = x86_64
license = custom
depends = gmp
source = http://numpi.dm.unipi.it/mpsolve-2.2/mpsolve.tgz
- source = http://numpi.dm.unipi.it/mpsolve-2.2/copyright.htm
sha256sums = 2b3ad94d9ba88492fedb7c33c8084aa14e97acb5c90e5a0558ed79ef29c9230f
- sha256sums = e8f83c91148adb6eb9a0802652640bfb060d903823cdf76f4c324cc1bb073292
pkgname = mpsolve2
diff --git a/PKGBUILD b/PKGBUILD
index 40ad386bfdcd..ee7506981eef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,30 @@
pkgname=mpsolve2
pkgver=2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Multiprecision rootfinder for complex roots of univariate polynomials (version 2)"
-url="http://numpi.dm.unipi.it/software/mpsolve"
+url="http://numpi.dm.unipi.it/mpsolve-2.2"
arch=('i686' 'x86_64')
license=('custom')
depends=('gmp')
-source=("http://numpi.dm.unipi.it/mpsolve-2.2/mpsolve.tgz"
- "http://numpi.dm.unipi.it/mpsolve-2.2/copyright.htm")
-sha256sums=('2b3ad94d9ba88492fedb7c33c8084aa14e97acb5c90e5a0558ed79ef29c9230f'
- 'e8f83c91148adb6eb9a0802652640bfb060d903823cdf76f4c324cc1bb073292')
+source=("${url}/mpsolve.tgz")
+sha256sums=('2b3ad94d9ba88492fedb7c33c8084aa14e97acb5c90e5a0558ed79ef29c9230f')
build () {
- cd ${srcdir}/MPSolve-${pkgver}
+ cd "${srcdir}/MPSolve-${pkgver}"
make
}
check () {
- cd ${srcdir}/MPSolve-${pkgver}
+ cd "${srcdir}/MPSolve-${pkgver}"
make check
}
package () {
- cd ${srcdir}
- sed -e 's/ background="sfondop.gif"//' -e 's#href="index.htm"#href="http://numpi.dm.unipi.it/mpsolve-2.2/index.htm"#' -i copyright.htm
- install -D -m644 copyright.htm -t "${pkgdir}/usr/share/licenses/${pkgname}"
- cd MPSolve-${pkgver}
+ cd "${srcdir}/MPSolve-${pkgver}"
+ install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" Copyright.txt
+ install -D -m644 -t "${pkgdir}/usr/share/doc/${pkgname}" Doc/*
+ install -D -m644 -t "${pkgdir}/usr/share/doc/${pkgname}/Data" Data/*
+ sed -i -e 's#\.\./Data/#Data/#' "${pkgdir}/usr/share/doc/${pkgname}"/*.htm
install -D -m755 unisolve ${pkgdir}/usr/bin/unisolve
}