summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore32
-rw-r--r--PKGBUILD35
-rw-r--r--remove-tempfix-ui.patch12
4 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9cac27fcf02b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mpvconfigurator
+ pkgdesc = Generate config for MPV using GUI
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/haasnhoff/mpvconfigurator
+ arch = x86_64
+ license = GPL2
+ depends = qt5-base
+ conflicts = mpvconfigurator-git
+ source = mpvconfigurator-0.2.tar.gz::https://github.com/haasnhoff/mpvconfigurator/archive/0.2.tar.gz
+ source = remove-tempfix-ui.patch
+ sha256sums = 06ede788f05ac97cddbf98f917f17f8271a2db5e4088b380c7ca1570867607b0
+ sha256sums = 9b7666548b43e19465feb3f8ddd56b6b5b59a17026880b7c424c78d2bd09cf69
+
+pkgname = mpvconfigurator
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0b8cc6c4e8bc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,32 @@
+# Created by https://www.gitignore.io/api/vim,archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+### Vim ###
+# swap
+[._]*.s[a-v][a-z]
+[._]*.sw[a-p]
+[._]s[a-v][a-z]
+[._]sw[a-p]
+# session
+Session.vim
+# temporary
+.netrwhist
+*~
+# auto-generated tag files
+tags
+
+# End of https://www.gitignore.io/api/vim,archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..368c32ec352f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Ye Jingchen <ye.jingchen@gmail.com>
+pkgname=mpvconfigurator
+pkgver=0.2
+pkgrel=1
+pkgdesc="Generate config for MPV using GUI"
+arch=('x86_64')
+url="https://github.com/haasnhoff/mpvconfigurator"
+license=('GPL2')
+depends=(qt5-base)
+makedepends=()
+conflicts=('mpvconfigurator-git')
+options=()
+install=
+source=("mpvconfigurator-$pkgver.tar.gz::https://github.com/haasnhoff/mpvconfigurator/archive/$pkgver.tar.gz"
+ "remove-tempfix-ui.patch")
+sha256sums=('06ede788f05ac97cddbf98f917f17f8271a2db5e4088b380c7ca1570867607b0'
+ '9b7666548b43e19465feb3f8ddd56b6b5b59a17026880b7c424c78d2bd09cf69')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -Np0 -i "$srcdir/remove-tempfix-ui.patch"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ mkdir -p build
+ cd build
+ qmake -o Makefile ../src/mpvconfigurator.pro
+ make -j$(nproc)
+}
+
+package() {
+ cd "$pkgname-$pkgver/build"
+ install -Dm755 mpvconfigurator "$pkgdir/usr/bin/mpvconfigurator"
+}
diff --git a/remove-tempfix-ui.patch b/remove-tempfix-ui.patch
new file mode 100644
index 000000000000..02261115e316
--- /dev/null
+++ b/remove-tempfix-ui.patch
@@ -0,0 +1,12 @@
+--- src/mpvconfigurator.pro.orig 2017-11-28 21:32:41.445023996 +0800
++++ src/mpvconfigurator.pro 2017-11-28 21:31:36.494128593 +0800
+@@ -52,8 +52,7 @@
+ tabmisc.ui \
+ tabextensions.ui \
+ unknownsettingstab.ui \
+- tabconfig.ui \
+- tempfix.ui
++ tabconfig.ui
+
+ QMAKE_CXXFLAGS += -std=c++11
+