summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--mqtt5-explorer.sh11
3 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86216d944afc..335e886a8885 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = mqtt5-explorer-bin
pkgdesc = A simple yet feature-rich client to visualize data of any MQTT broker.
- pkgver = 1.13.1
+ pkgver = 1.14.0
pkgrel = 1
url = https://github.com/Omniaevo/mqtt5-explorer
arch = x86_64
license = GPL-3.0-only
makedepends = fuse2
depends = electron28
- provides = mqtt5-explorer=1.13.1
+ provides = mqtt5-explorer=1.14.0
conflicts = mqtt5-explorer
- source = mqtt5-explorer-1.13.1.AppImage::https://github.com/Omniaevo/mqtt5-explorer/releases/download/v1.13.1/mqtt5-explorer-1.13.1-linux-x86_64.AppImage
+ source = mqtt5-explorer-1.14.0.AppImage::https://github.com/Omniaevo/mqtt5-explorer/releases/download/v1.14.0/mqtt5-explorer-1.14.0-linux-x86_64.AppImage
source = mqtt5-explorer.sh
- sha256sums = 2159190761231850a76eb7217b06bca07c8a02c64b34a9dd6419e67b55042363
- sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
+ sha256sums = 09aaf40cc4dbee91560014133d6dcdd3ccdeabc6cd7c4b9003d60e80824d22af
+ sha256sums = 24c1c5b90cba47cd3d7a3ff11a934fcdbb499f8c56423d22009ef33a775e2d21
pkgname = mqtt5-explorer-bin
diff --git a/PKGBUILD b/PKGBUILD
index 8a291175dfd9..a066ec58fbee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=mqtt5-explorer-bin
_pkgname="MQTT5 Explorer"
-pkgver=1.13.1
+pkgver=1.14.0
_electronversion=28
pkgrel=1
pkgdesc="A simple yet feature-rich client to visualize data of any MQTT broker."
@@ -20,8 +20,8 @@ source=(
"${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux-${CARCH}.AppImage"
"${pkgname%-bin}.sh"
)
-sha256sums=('2159190761231850a76eb7217b06bca07c8a02c64b34a9dd6419e67b55042363'
- 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+sha256sums=('09aaf40cc4dbee91560014133d6dcdd3ccdeabc6cd7c4b9003d60e80824d22af'
+ '24c1c5b90cba47cd3d7a3ff11a934fcdbb499f8c56423d22009ef33a775e2d21')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/mqtt5-explorer.sh b/mqtt5-explorer.sh
index 7ddcaab8d734..79987c30c522 100644
--- a/mqtt5-explorer.sh
+++ b/mqtt5-explorer.sh
@@ -7,10 +7,17 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export ELECTRON_FORCE_IS_PACKAGED=true
+export ELECTRON_RUN_AS_NODE=0
+export ELECTRON_DISABLE_SECURITY_WARNINGS=true
export NODE_ENV=production
+export XDG_CONFIG_HOME="${XDG_CONFIG_HOME:-$HOME/.config}"
+_FLAGS_FILE="${XDG_CONFIG_HOME}/@appname@-flags.conf"
+if [ -r "${_FLAGS_FILE}" ]; then
+ _USER_FLAGS="$(cat "${_FLAGS_FILE}")"
+fi
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "${_USER_FLAGS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "${_USER_FLAGS}" "$@" || exit $?
fi \ No newline at end of file