summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb4d8699f972
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mstch
+ pkgdesc = mstch is a complete implementation of {{mustache}} templates using modern C++
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/no1msd/mstch
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = cmake
+ depends = boost
+ source = https://github.com/no1msd/mstch/archive/1.0.2.tar.gz
+ md5sums = 306e7fead7480884f698ab47a6082e18
+
+pkgname = mstch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb2e2186e37e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jitang Zheng <jitang.zheng@gmail.com>
+pkgname=mstch
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="mstch is a complete implementation of {{mustache}} templates using modern C++"
+arch=('x86_64' 'i686')
+url="https://github.com/no1msd/mstch"
+license=('MIT')
+depends=("boost")
+makedepends=('cmake')
+source=("https://github.com/no1msd/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('306e7fead7480884f698ab47a6082e18')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=$pkgdir/usr .
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make install
+}