summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90114075141b..772e6343927e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,7 +16,7 @@ pkgbase = mu-wizard-git
optdepends = pm: alternative password manager
provides = mu-wizard
conflicts = mu-wizard
- source = git+https://github.com/cemkeylan/mu-wizard
+ source = mu-wizard::git+https://github.com/cemkeylan/mu-wizard
md5sums = SKIP
pkgname = mu-wizard-git
diff --git a/PKGBUILD b/PKGBUILD
index 63f9df9d849d..7f9e2ce503f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,35 @@
# Maintainer : Yuu $(echo \<yuu-tutamail+com\>|sed s/\+/./g\;s/\-/@/)
# Upstream author : Cem Keylan <https://github.com/cemkeylan>
-pkgname=mu-wizard-git
+_pkgname="mu-wizard"
+pkgname="${_pkgname}-git"
pkgver=0.r42.g76f5844
pkgrel=1
pkgdesc="Shell script to easily setup mu4e on Emacs"
arch=('any')
-url=https://github.com/cemkeylan/mu-wizard
+_url=https://github.com/cemkeylan/$_pkgname
+url=$_url
license=('GPL3')
depends=('isync' 'msmtp' 'mu' 'pass' 'sh')
makedepends=('git')
optdepends=('pash: alternative password manager'
'pm: alternative password manager')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-install="${pkgname%-git}.install"
-source=("git+$url")
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+install="${_pkgname}.install"
+source=("${_pkgname}::git+${_url}")
md5sums=('SKIP')
# Git, no tags available.
# Use number of revisions since beginning of the history.
pkgver() {
- cd "${pkgname%-git}"
+ cd "${_pkgname}"
printf '0.r%s.g%s' \
"$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/${_pkgname}"
make DESTDIR="$pkgdir/" install
install -Dm644 README.org -t "$pkgdir/usr/share/doc/${_pkgname}/"
}