summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-compiling-with-kernels-4.14.patch36
-rw-r--r--PKGBUILD11
3 files changed, 47 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 320500d39a57..c523067ce397 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Sun Dec 10 17:47:34 UTC 2017
pkgbase = mumudvb
pkgdesc = Redistribute a stream from DVB on a network in multicast or in HTTP unicast
pkgver = 2.1.0
@@ -13,8 +11,10 @@ pkgbase = mumudvb
depends = glibc
source = https://github.com/braice/MuMuDVB/archive/2.1.0.zip
source = mumudvb.conf
+ source = 0001-Fix-compiling-with-kernels-4.14.patch
sha256sums = 43706f0d899cebc934dc7a2076497d221b44464b4d986dc263dd2a6c91ae9088
sha256sums = abe3c74a528f59b990e18f91858cb9bb9dd61c715c8904eb561aa7ee4cb79281
+ sha256sums = f9cc41c30a204ddf71522de6f5f0fa0432c7f02a62dbd521b95d3258003dc5dd
pkgname = mumudvb
diff --git a/0001-Fix-compiling-with-kernels-4.14.patch b/0001-Fix-compiling-with-kernels-4.14.patch
new file mode 100644
index 000000000000..53573292a238
--- /dev/null
+++ b/0001-Fix-compiling-with-kernels-4.14.patch
@@ -0,0 +1,36 @@
+From e948d2c21cee69c46d91cc178d4a316dcf99a680 Mon Sep 17 00:00:00 2001
+From: Brice Dubost <mumudvb@braice.net>
+Date: Sat, 25 Nov 2017 20:21:10 -0500
+Subject: [PATCH] Fix compiling with kernels > 4.14
+
+(cherry picked from commit 596f7dbebd2590f7e77cf755af46952f340ddb97)
+---
+ src/scam_common.h | 12 ++++++++++++
+ 1 file changed, 12 insertions(+)
+
+diff --git a/src/scam_common.h b/src/scam_common.h
+index 9f83b13..54cfd78 100644
+--- a/src/scam_common.h
++++ b/src/scam_common.h
+@@ -59,6 +59,18 @@
+ #define DECSA_DEFAULT_DELAY 500000
+ #define SEND_DEFAULT_DELAY 1500000
+
++//Quick hack around the removal of ca_pid_t and CA_GET_PID in recent kernels
++//https://github.com/torvalds/linux/commit/833ff5e7feda1a042b83e82208cef3d212ca0ef1
++#ifndef CA_SET_PID
++typedef struct ca_pid {
++ unsigned int pid;
++ int index; /* -1 == disable*/
++ } ca_pid_t;
++//We should not be able to get it so a number that is unlikely to happen
++#define CA_SET_PID 42424242
++#endif
++
++
+ /** @brief the parameters for the scam
+ * This structure contain the parameters needed for the SCAM
+ */
+--
+2.18.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 29c325ee4680..c028cf81a605 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,10 +13,17 @@ url="http://www.mumudvb.net/"
license=('GPL2')
depends=('glibc')
source=("https://github.com/braice/${_gitname}/archive/${pkgver}.zip"
- "mumudvb.conf")
+ "mumudvb.conf"
+ "0001-Fix-compiling-with-kernels-4.14.patch")
install="mumudvb.install"
sha256sums=('43706f0d899cebc934dc7a2076497d221b44464b4d986dc263dd2a6c91ae9088'
- 'abe3c74a528f59b990e18f91858cb9bb9dd61c715c8904eb561aa7ee4cb79281')
+ 'abe3c74a528f59b990e18f91858cb9bb9dd61c715c8904eb561aa7ee4cb79281'
+ 'f9cc41c30a204ddf71522de6f5f0fa0432c7f02a62dbd521b95d3258003dc5dd')
+
+prepare() {
+ cd "${srcdir}/${_gitname}-${pkgver}"
+ patch -p1 < "${srcdir}"/0001-Fix-compiling-with-kernels-4.14.patch
+}
build() {
cd "${srcdir}/${_gitname}-${pkgver}"