summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
-rw-r--r--hooks.install7
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca3030a5ee53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = muslcc-arm-linux-musleabi-cross-bin
+ pkgdesc = Static musl-based cross-compilation toolchain provided by musl.cc
+ pkgver = 11.2.1
+ pkgrel = 1
+ url = https://musl.cc/
+ install = hooks.install
+ arch = x86_64
+ arch = i686
+ license = MIT
+ options = !strip
+ source = https://more.musl.cc/11.2.1/x86_64-linux-musl/arm-linux-musleabi-cross.tgz
+ source = hooks.install
+ sha512sums = f37de55027a8ab037b2fab1e890719021cc9e53d6ee0627257b2b92e5eeb30847826bd132415898df70735295c80c6bb0a1bb27676bb9029ad255c5fe2753f0f
+ sha512sums = b16a6b5f20dde4121df456220c99304e4b6c25c5004b4ab5b923f94c603fe042076d2fb81d545926d940d19e02ccc3f097c0c1878abf6aa42dfdccbabd0e6f64
+
+pkgname = muslcc-arm-linux-musleabi-cross-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c94090346d79
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tgz
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf3fac164efa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Danilo Bargen <aur at dbrgn dot ch>
+pkgname=muslcc-arm-linux-musleabi-cross-bin
+name=${pkgname/-bin/}
+name=${name/muslcc-/}
+pkgver=11.2.1
+pkgrel=1
+pkgdesc="Static musl-based cross-compilation toolchain provided by musl.cc"
+arch=('x86_64' 'i686')
+url="https://musl.cc/"
+license=('MIT')
+depends=()
+makedepends=()
+options=('!strip')
+source=(
+ "https://more.musl.cc/$pkgver/$CARCH-linux-musl/arm-linux-musleabi-cross.tgz"
+ "hooks.install"
+)
+install=hooks.install
+sha512sums=(
+ 'f37de55027a8ab037b2fab1e890719021cc9e53d6ee0627257b2b92e5eeb30847826bd132415898df70735295c80c6bb0a1bb27676bb9029ad255c5fe2753f0f'
+ 'b16a6b5f20dde4121df456220c99304e4b6c25c5004b4ab5b923f94c603fe042076d2fb81d545926d940d19e02ccc3f097c0c1878abf6aa42dfdccbabd0e6f64'
+)
+
+package() {
+ # Copy toolchain to /opt/muslcc/
+ mkdir -p "$pkgdir/opt/muslcc/"
+ cp -R "$srcdir/$name/" "$pkgdir/opt/muslcc/"
+
+ # Add to PATH
+ mkdir -p "$pkgdir/etc/profile.d/"
+ echo -e "#!/bin/sh\nexport PATH=\$PATH:\"/opt/muslcc/$name/bin/\"" > "$pkgdir/etc/profile.d/$name.sh"
+ chmod 0644 "$pkgdir/etc/profile.d/$name.sh"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/hooks.install b/hooks.install
new file mode 100644
index 000000000000..42ae71ea8f71
--- /dev/null
+++ b/hooks.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo "muslcc toolchain installed to /opt/muslcc/arm-linux-musleabi-cross/."
+ echo "The PATH variable will be updated on re-login. To immediately load it:"
+ echo ""
+ echo " source /etc/profile.d/arm-linux-musleabi-cross.sh"
+ echo ""
+}