summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD124
2 files changed, 128 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dea0a1abe222..452b0545c341 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,14 @@
pkgbase = mutter-git
pkgdesc = Window manager and compositor for GNOME
- pkgver = 46.alpha+r124+gecdd2aeb8
+ pkgver = 46.0+r26+ga834eb5c9
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/mutter
arch = x86_64
- license = GPL
+ license = GPL-2.0-or-later
+ checkdepends = gnome-session
+ checkdepends = python-dbusmock
+ checkdepends = wireplumber
+ checkdepends = zenity
makedepends = egl-wayland
makedepends = gi-docgen
makedepends = git
@@ -15,26 +19,63 @@ pkgbase = mutter-git
makedepends = wayland-protocols
makedepends = xorg-server
makedepends = xorg-server-xvfb
+ depends = at-spi2-core
+ depends = cairo
depends = colord
depends = dconf
+ depends = fontconfig
+ depends = fribidi
+ depends = gcc-libs
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
depends = gnome-desktop-4
depends = gnome-settings-daemon
depends = graphene
depends = gsettings-desktop-schemas
+ depends = gtk4
+ depends = harfbuzz
+ depends = iio-sensor-proxy
depends = lcms2
depends = libcanberra
+ depends = libcolord
+ depends = libdisplay-info
+ depends = libdrm
+ depends = libei
+ depends = libglvnd
depends = libgudev
+ depends = libice
depends = libinput
+ depends = libpipewire
depends = libsm
depends = libsysprof-capture
+ depends = libwacom
+ depends = libx11
+ depends = libxau
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxcursor
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxi
+ depends = libxinerama
+ depends = libxkbcommon
depends = libxkbcommon-x11
depends = libxkbfile
+ depends = libxrandr
+ depends = libxtst
+ depends = mesa
+ depends = pango
depends = pipewire
+ depends = pixman
+ depends = python
depends = startup-notification
+ depends = systemd-libs
+ depends = wayland
depends = xorg-xwayland
- depends = libei
source = git+https://gitlab.gnome.org/GNOME/mutter.git
- sha256sums = SKIP
+ b2sums = SKIP
pkgname = mutter-git
provides = mutter
diff --git a/PKGBUILD b/PKGBUILD
index 0ad797069207..e04841afdb72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,85 @@
+# based on https://gitlab.archlinux.org/archlinux/packaging/packages/mutter/-/blob/dbc5b50d4be573129533e6a4d9aebd0d47405b26/PKGBUILD
+
+# -- Arch credits
+# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Maintainer: Fabian Bornschein <fabiscafe@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Michael Kanis <mkanis_at_gmx_dot_de>
+# --
+
# Maintainer: Vitaly Ankh (vitalyr) <vitalyankh@gmail.com>
# Contributor: jonathon <https://aur.archlinux.org/account/jonathon>
# Contributor: Ignacy KuchciƄski (ignapk) <ignacykuchcinski@gmail.com>
# Contributor: Simon Gardling <titaniumtown@gmail.com>
# Contributor: Ricardo Liang (rliang) <ricardoliang@gmail.com>
-_pkgname=mutter
pkgbase=mutter-git
pkgname=(
mutter-git
mutter-docs-git
)
-pkgver=46.alpha+r124+gecdd2aeb8
+pkgver=46.0+r26+ga834eb5c9
pkgrel=1
pkgdesc="Window manager and compositor for GNOME"
url="https://gitlab.gnome.org/GNOME/mutter"
arch=(x86_64)
-license=(GPL)
+license=(GPL-2.0-or-later)
depends=(
+ at-spi2-core
+ cairo
colord
dconf
+ fontconfig
+ fribidi
+ gcc-libs
+ gdk-pixbuf2
+ glib2
+ glibc
gnome-desktop-4
gnome-settings-daemon
graphene
gsettings-desktop-schemas
+ gtk4
+ harfbuzz
+ iio-sensor-proxy
lcms2
libcanberra
+ libcolord
+ libdisplay-info
+ libdrm
+ libei
+ libglvnd
libgudev
+ libice
libinput
+ libpipewire
libsm
libsysprof-capture
+ libwacom
+ libx11
+ libxau
+ libxcb
+ libxcomposite
+ libxcursor
+ libxdamage
+ libxext
+ libxfixes
+ libxi
+ libxinerama
+ libxkbcommon
libxkbcommon-x11
libxkbfile
+ libxrandr
+ libxtst
+ mesa
+ pango
pipewire
+ pixman
+ python
startup-notification
+ systemd-libs
+ wayland
xorg-xwayland
- libei
)
makedepends=(
egl-wayland
@@ -48,55 +93,54 @@ makedepends=(
xorg-server
xorg-server-xvfb
)
-source=("git+https://gitlab.gnome.org/GNOME/mutter.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd $_pkgname
-}
+checkdepends=(
+ gnome-session
+ python-dbusmock
+ wireplumber
+ zenity
+)
+source=('git+https://gitlab.gnome.org/GNOME/mutter.git')
+b2sums=('SKIP')
pkgver() {
- cd $_pkgname
+ cd mutter
git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
}
-prepare() {
- cd $_pkgname
-}
-
build() {
+ local meson_options=(
+ -D docs=true
+ -D egl_device=true
+ -D installed_tests=false
+ -D libdisplay_info=enabled
+ -D wayland_eglstream=true
+ )
+
CFLAGS="${CFLAGS/-O2/-O3} -fno-semantic-interposition"
LDFLAGS+=" -Wl,-Bsymbolic-functions"
- arch-meson mutter build \
- -D egl_device=true \
- -D wayland_eglstream=true \
- -D docs=true \
- -D installed_tests=false
+ arch-meson mutter build "${meson_options[@]}"
meson compile -C build
}
-_check() (
- mkdir -p -m 700 "${XDG_RUNTIME_DIR:=$PWD/runtime-dir}"
- glib-compile-schemas "${GSETTINGS_SCHEMA_DIR:=$PWD/build/data}"
- export XDG_RUNTIME_DIR GSETTINGS_SCHEMA_DIR
-
- #pipewire &
- #_p1=$!
-
- #wireplumber &
- #_p2=$!
-
- #trap "kill $_p1 $_p2; wait" EXIT
-
- #meson test -C build --print-errorlogs -t 3
+check() (
+ export XDG_RUNTIME_DIR="$PWD/rdir" GSETTINGS_SCHEMA_DIR="$PWD/build/data"
+ mkdir -p -m 700 "$XDG_RUNTIME_DIR"
+ glib-compile-schemas "$GSETTINGS_SCHEMA_DIR"
+
+ export NO_AT_BRIDGE=1 GTK_A11Y=none
+ export MUTTER_DEBUG_DUMMY_MODE_SPECS="800x600@10.0"
+
+ # Tests fail:
+ # mutter:cogl+cogl/conform / cogl-test-offscreen-texture-formats-gles2
+ # mutter:core+mutter/stacking / fullscreen-maximize
+ ## https://gitlab.gnome.org/GNOME/mutter/-/issues/3343
+ xvfb-run -s '-nolisten local +iglx -noreset' \
+ mutter/src/tests/meta-dbus-runner.py --launch=pipewire --launch=wireplumber \
+ meson test -C build --no-suite 'mutter/kvm' --no-rebuild \
+ --print-errorlogs --timeout-multiplier 10 --setup plain ||:
)
-check() {
- dbus-run-session xvfb-run -s '-nolisten local +iglx -noreset' \
- bash -c "$(declare -f _check); _check"
-}
-
_pick() {
local p="$1" f d; shift
for f; do
@@ -124,5 +168,3 @@ package_mutter-docs-git() {
mv docs/* "$pkgdir"
}
-
-# vim:set sw=2 et: