summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO51
-rw-r--r--001-timezone.patch25
-rw-r--r--002-in_progress.patch26
-rw-r--r--003-mythcount.patch23
-rw-r--r--004-exiv2.patch18
-rw-r--r--005-mythuiwebbrowser.patch58
-rw-r--r--PKGBUILD45
7 files changed, 29 insertions, 217 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22d117074e5a..a5ee9b01b2cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,81 +1,58 @@
pkgbase = mythtv
pkgdesc = A Homebrew PVR project
- pkgver = 30.0
- pkgrel = 7
+ pkgver = 31.0
+ pkgrel = 1
epoch = 1
url = https://www.mythtv.org/
- arch = x86_64
+ arch = any
license = GPL
makedepends = git
makedepends = help2man
makedepends = yasm
makedepends = mariadb-libs
- makedepends = libxml2
makedepends = libcec
makedepends = libcdio
makedepends = lirc
makedepends = perl-io-socket-inet6
makedepends = perl-libwww
makedepends = perl-dbd-mysql
- makedepends = python2-lxml
+ makedepends = python-lxml
makedepends = perl-xml-simple
makedepends = perl-xml-xpath
- depends = libass
+ makedepends = python-requests
depends = qt5-script
- depends = libavc1394
depends = fftw
depends = exiv2
depends = taglib
- depends = libva
- depends = libiec61883
depends = perl-net-upnp
- depends = urlgrabber
- depends = libsamplerate
- depends = qt5-webkit
- depends = x265
- depends = x264
- depends = jack
- depends = libvpx
- depends = libvdpau
- depends = lame
+ depends = ffmpeg
depends = libxinerama
- depends = libpulse
depends = libxrandr
- depends = mysql-python
+ depends = qt5-webkit
+ depends = python-mysqlclient
depends = libxnvctrl
depends = libhdhomerun
- depends = libbluray
+ depends = python-simplejson
+ depends = python-future
optdepends = glew: for GPU commercial flagging
optdepends = libcec: for consumer electronics control capabilities
- optdepends = libxml2: to read blu-ray metadata
optdepends = libhdhomerun: to work properly with HDHomerun devices
optdepends = mariadb: Database-Backend for server deployment
optdepends = mariadb-clients: Database-Frontend for client deployment
- optdepends = python2-future: for metadata-lookup / cover art
- optdepends = python2-requests: for metadata-lookup / cover art
- optdepends = python2-requests-cache: for metadata-lookup / cover art
+ optdepends = python-requests: for metadata-lookup / cover art
+ optdepends = python-requests-cache: for metadata-lookup / cover art
conflicts = myththemes
conflicts = mythplugins-mythvideo
replaces = myththemes
replaces = mythplugins-mythvideo
- source = mythtv-30.0.tar.gz::https://github.com/MythTV/mythtv/archive/v30.0.tar.gz
+ source = mythtv-31.0.tar.gz::https://github.com/MythTV/mythtv/archive/v31.0.tar.gz
source = mythbackend.service
source = 99-mythbackend.rules
source = sysusers.d
- source = 001-timezone.patch
- source = 002-in_progress.patch
- source = 003-mythcount.patch
- source = 004-exiv2.patch
- source = 005-mythuiwebbrowser.patch
- sha256sums = 7f7ae9b8927659616f181afc12d7ddc26b0a4b0d13982e2586985f4770640b43
+ sha256sums = 096ace898e4a075293bb720bd9f33ae5818650f0ef62e722db290c68e522612f
sha256sums = 086f573884e4df1ff6e6e8de5a423a9ff900166acfe085abe65b62f32730e4a3
sha256sums = ecfd02bbbef5de9773f4de2c52e9b2b382ce8137735f249d7900270d304fd333
sha256sums = 470de0a4050c16c7af11a0e5cfe2810b7daae42df4acf5456c7eae274dc7c5ae
- sha256sums = 965b279c2a5c51229f0cf42b37e1df0413e22375c9796f85d10f7a5921478a42
- sha256sums = ca0084165572f679bee7813653dd67fdb7eba528e1add56d6bd6ba5394d571ea
- sha256sums = 64575e3bf452d473970b1c752152b2404397012c7eb6ba64c0d445234135b5d2
- sha256sums = 689aec9cf0cb01e29c63e39381405875ffceea037b093d38f0f3e1519c200556
- sha256sums = debb5ee0b15d12e6e5ab94ab1e7a64f86721f226c6d326c53db783258409ce2d
pkgname = mythtv
diff --git a/001-timezone.patch b/001-timezone.patch
deleted file mode 100644
index 520299a4aa7d..000000000000
--- a/001-timezone.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Index: mythtv/programs/mythfrontend/prevreclist.cpp
-===================================================================
---- mythtv/programs/mythfrontend/prevreclist.cpp (revision 0e7e57f9c2eb0e2c4f47dcb30788a4e54d6808ba)
-+++ mythtv/programs/mythfrontend/prevreclist.cpp (revision c08b7ae0e7589dbe54d817a1d6296688e576d675)
-@@ -237,5 +237,7 @@
- bool PrevRecordedList::LoadDates(void)
- {
-- QString querystr = "SELECT DISTINCT YEAR(starttime), MONTH(starttime) "
-+ QString querystr = "SELECT DISTINCT "
-+ "YEAR(CONVERT_TZ(starttime,'UTC','SYSTEM')), "
-+ "MONTH(CONVERT_TZ(starttime,'UTC','SYSTEM')) "
- "FROM oldrecorded "
- "WHERE oldrecorded.future = 0 " + m_where;
-@@ -404,6 +406,9 @@
- MSqlBindings bindings;
- QString sql = " AND oldrecorded.title = :TITLE " + m_where;
-- int selected = m_titleList->GetCurrentPos();
-- bindings[":TITLE"] = m_titleData[selected]->GetTitle();
-+ uint selected = m_titleList->GetCurrentPos();
-+ if (selected < m_titleData.size())
-+ bindings[":TITLE"] = m_titleData[selected]->GetTitle();
-+ else
-+ bindings[":TITLE"] = "";
- if (!m_title.isEmpty())
- bindings[":MTITLE"] = m_title;
diff --git a/002-in_progress.patch b/002-in_progress.patch
deleted file mode 100644
index 345d6ec796cd..000000000000
--- a/002-in_progress.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: mythtv/libs/libmythtv/mythplayer.cpp
-===================================================================
---- mythtv/libs/libmythtv/mythplayer.cpp (revision 2032ac013221e9367c9f720459e5e9f546caf66e)
-+++ mythtv/libs/libmythtv/mythplayer.cpp (revision 0bf0880d3e7ff0f78d1b90953e1f48618421e62d)
-@@ -3174,6 +3174,6 @@
- QString subfn = player_ctx->m_buffer->GetSubtitleFilename();
- TVState desiredState = player_ctx->GetState();
-- bool isInProgress =
-- desiredState == kState_WatchingRecording || kState_WatchingLiveTV;
-+ bool isInProgress = (desiredState == kState_WatchingRecording ||
-+ desiredState == kState_WatchingLiveTV);
- if (GetSubReader())
- GetSubReader()->LoadExternalSubtitles(subfn, isInProgress &&
-Index: mythtv/libs/libmythtv/playercontext.cpp
-===================================================================
---- mythtv/libs/libmythtv/playercontext.cpp (revision 2032ac013221e9367c9f720459e5e9f546caf66e)
-+++ mythtv/libs/libmythtv/playercontext.cpp (revision 0bf0880d3e7ff0f78d1b90953e1f48618421e62d)
-@@ -404,6 +404,6 @@
- {
- QString subfn = m_buffer->GetSubtitleFilename();
-- bool isInProgress =
-- desiredState == kState_WatchingRecording || kState_WatchingLiveTV;
-+ bool isInProgress = (desiredState == kState_WatchingRecording ||
-+ desiredState == kState_WatchingLiveTV);
- if (!subfn.isEmpty() && player->GetSubReader())
- player->GetSubReader()->LoadExternalSubtitles(subfn, isInProgress);
diff --git a/003-mythcount.patch b/003-mythcount.patch
deleted file mode 100644
index 599384a1cbb1..000000000000
--- a/003-mythcount.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff --git a/bindings/php/MythBackend.php b/bindings/php/MythBackend.php
-index 54472e9489..9360e8801e 100644
---- a/bindings/php/MythBackend.php
-+++ b/bindings/php/MythBackend.php
-@@ -42,7 +42,7 @@ class MythBackend {
- ."need to check your mythweb.conf file or re-run mythtv-setup",
- FATAL);
- }
--
-+
- if (!isset($Backends[$host]))
- $Backends[$host] = array();
-
-@@ -191,7 +191,8 @@ class MythBackend {
- // Parse the records, starting at the offset point
- $row = 0;
- $col = 0;
-- $count = count($records);
-+ if ($records) $count = count($records);
-+ else $count = 0;
- for($i = $offset; $i < $count; $i++) {
- $rows[$row][$col] = $records[$i];
- // Every $NUMPROGRAMLINES fields (0 through ($NUMPROGRAMLINES-1)) means
diff --git a/004-exiv2.patch b/004-exiv2.patch
deleted file mode 100644
index bece0d724e5c..000000000000
--- a/004-exiv2.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/libs/libmythmetadata/imagemetadata.cpp
-+++ b/libs/libmythmetadata/imagemetadata.cpp
-@@ -7,14 +7,7 @@
- #include "exitcodes.h" // for ffprobe
-
- // libexiv2 for Exif metadata
--//#include <exiv2/exiv2.hpp>
--// Note: Older versions of Exiv2 don't have the exiv2.hpp include
--// file. Using image.hpp instead seems to work.
--#ifdef _MSC_VER
--#include <exiv2/src/image.hpp>
--#else
--#include <exiv2/image.hpp>
--#endif
-+#include <exiv2/exiv2.hpp>
-
- // To read FFMPEG Metadata
- extern "C" {
diff --git a/005-mythuiwebbrowser.patch b/005-mythuiwebbrowser.patch
deleted file mode 100644
index 3e9eb8936f08..000000000000
--- a/005-mythuiwebbrowser.patch
+++ /dev/null
@@ -1,58 +0,0 @@
---- a/libs/libmythui/mythuiwebbrowser.cpp
-+++ b/libs/libmythui/mythuiwebbrowser.cpp
-@@ -873,4 +873,8 @@
- void MythUIWebBrowser::Init(void)
- {
-+ // only do the initialisation for widgets not being stored in the global object store
-+ if (parent() == GetGlobalObjectStore())
-+ return;
-+
- if (m_initialized)
- return;
-@@ -1128,4 +1132,7 @@
- void MythUIWebBrowser::SetActive(bool active)
- {
-+ if (!m_browser)
-+ return;
-+
- if (m_active == active)
- return;
-@@ -1326,4 +1333,7 @@
- void MythUIWebBrowser::Scroll(int dx, int dy)
- {
-+ if (!m_browser)
-+ return;
-+
- QPoint startPos = m_browser->page()->currentFrame()->scrollPosition();
- QPoint endPos = startPos + QPoint(dx, dy);
-@@ -1435,4 +1445,7 @@
- void MythUIWebBrowser::UpdateScrollBars(void)
- {
-+ if (!m_browser)
-+ return;
-+
- QPoint position = m_browser->page()->currentFrame()->scrollPosition();
- if (m_verticalScrollbar)
-@@ -1461,5 +1474,5 @@
- UpdateScrollBars();
-
-- if (!m_image)
-+ if (!m_image || !m_browser)
- return;
-
-@@ -1480,4 +1493,7 @@
- void MythUIWebBrowser::Pulse(void)
- {
-+ if (!m_browser)
-+ return;
-+
- if (m_scrollAnimation.IsActive() &&
- m_destinationScrollPos !=
-@@ -1522,4 +1538,7 @@
- bool MythUIWebBrowser::keyPressEvent(QKeyEvent *event)
- {
-+ if (!m_browser)
-+ return false;
-+
- QStringList actions;
- bool handled = false;
diff --git a/PKGBUILD b/PKGBUILD
index 544fe57b5897..af405cd5e742 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,48 +6,35 @@
# Contributor: dorphell <dorphell@archlinux.org>
pkgname=mythtv
-pkgver=30.0
-pkgrel=7
+pkgver=31.0
+pkgrel=1
epoch=1
pkgdesc="A Homebrew PVR project"
-arch=('x86_64')
+arch=('any')
url="https://www.mythtv.org/"
license=('GPL')
-depends=('libass' 'qt5-script' 'libavc1394' 'fftw' 'exiv2' 'taglib' 'libva' 'libiec61883' 'perl-net-upnp' 'urlgrabber' 'libsamplerate'
- 'qt5-webkit' 'x265' 'x264' 'jack' 'libvpx' 'libvdpau' 'lame' 'libxinerama' 'libpulse' 'libxrandr' 'mysql-python' 'libxnvctrl'
- 'libhdhomerun' 'libbluray')
-makedepends=('git' 'help2man' 'yasm' 'mariadb-libs' 'libxml2' 'libcec' 'libcdio' 'lirc' 'perl-io-socket-inet6' 'perl-libwww'
- 'perl-dbd-mysql' 'python2-lxml' 'perl-xml-simple' 'perl-xml-xpath')
+depends=('qt5-script' 'fftw' 'exiv2' 'taglib' 'perl-net-upnp' 'ffmpeg' 'libxinerama' 'libxrandr'
+ 'qt5-webkit' 'python-mysqlclient' 'libxnvctrl' 'libhdhomerun' 'python-simplejson' 'python-future')
+makedepends=('git' 'help2man' 'yasm' 'mariadb-libs' 'libcec' 'libcdio' 'lirc' 'perl-io-socket-inet6' 'perl-libwww'
+ 'perl-dbd-mysql' 'python-lxml' 'perl-xml-simple' 'perl-xml-xpath' 'python-requests')
optdepends=('glew: for GPU commercial flagging'
'libcec: for consumer electronics control capabilities'
- 'libxml2: to read blu-ray metadata'
'libhdhomerun: to work properly with HDHomerun devices'
'mariadb: Database-Backend for server deployment'
'mariadb-clients: Database-Frontend for client deployment'
- 'python2-future: for metadata-lookup / cover art'
- 'python2-requests: for metadata-lookup / cover art'
- 'python2-requests-cache: for metadata-lookup / cover art')
+ 'python-requests: for metadata-lookup / cover art'
+ 'python-requests-cache: for metadata-lookup / cover art')
conflicts=('myththemes' 'mythplugins-mythvideo')
replaces=('myththemes' 'mythplugins-mythvideo')
source=("$pkgname-$pkgver.tar.gz::https://github.com/MythTV/$pkgname/archive/v$pkgver.tar.gz"
'mythbackend.service'
'99-mythbackend.rules'
'sysusers.d'
- '001-timezone.patch'
- '002-in_progress.patch'
- '003-mythcount.patch'
- '004-exiv2.patch'
- '005-mythuiwebbrowser.patch'
)
-sha256sums=('7f7ae9b8927659616f181afc12d7ddc26b0a4b0d13982e2586985f4770640b43'
+sha256sums=('096ace898e4a075293bb720bd9f33ae5818650f0ef62e722db290c68e522612f'
'086f573884e4df1ff6e6e8de5a423a9ff900166acfe085abe65b62f32730e4a3'
'ecfd02bbbef5de9773f4de2c52e9b2b382ce8137735f249d7900270d304fd333'
- '470de0a4050c16c7af11a0e5cfe2810b7daae42df4acf5456c7eae274dc7c5ae'
- '965b279c2a5c51229f0cf42b37e1df0413e22375c9796f85d10f7a5921478a42'
- 'ca0084165572f679bee7813653dd67fdb7eba528e1add56d6bd6ba5394d571ea'
- '64575e3bf452d473970b1c752152b2404397012c7eb6ba64c0d445234135b5d2'
- '689aec9cf0cb01e29c63e39381405875ffceea037b093d38f0f3e1519c200556'
- 'debb5ee0b15d12e6e5ab94ab1e7a64f86721f226c6d326c53db783258409ce2d')
+ '470de0a4050c16c7af11a0e5cfe2810b7daae42df4acf5456c7eae274dc7c5ae')
prepare() {
cd $pkgname-$pkgver/$pkgname
@@ -61,7 +48,6 @@ prepare() {
patch -Np1 < "../../$src"
done
- find 'bindings/python' 'contrib' 'programs/scripts' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
}
build() {
@@ -71,16 +57,15 @@ build() {
./configure --prefix=/usr \
--cpu="$ARCH" \
--disable-altivec \
- --enable-audio-jack \
--disable-distcc \
- --enable-libfftw3 \
+ --enable-pic \
--enable-libmp3lame \
--enable-libvpx \
--enable-libx264 \
--enable-libx265 \
- --enable-vaapi \
- --python=python2 \
- --perl-config-opts=INSTALLDIRS=vendor
+ --enable-libvpx \
+ --enable-libxvid \
+ --perl-config-opts=INSTALLDIRS=vendor
make
}