summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4ba44ee2c68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Fri Jan 8 00:03:29 UTC 2016
+pkgbase = namhyung-global-git
+ pkgdesc = GNU Global with extra goodies for Linux kernel development
+ pkgver = e8571bc9eb
+ pkgrel = 1
+ url = https://github.com/namhyung/global
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ provides = namhyung-global
+ source = git+https://github.com/namhyung/global.git
+ md5sums = SKIP
+
+pkgname = namhyung-global-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..345c2bb00605
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mitchel Humpherys <mitch.special@gmail.com>
+
+pkgname=namhyung-global-git
+_gitname=global
+pkgver=e8571bc9eb
+pkgrel=1
+pkgdesc="GNU Global with extra goodies for Linux kernel development"
+arch=(i686 x86_64)
+url=https://github.com/namhyung/global
+license=(GPL)
+makedepends=(git)
+source=(git+https://github.com/namhyung/global.git)
+md5sums=(SKIP)
+provides=(namhyung-global)
+
+pkgver() {
+ cd $_gitname
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ make DESTDIR="$pkgdir/" install
+}