summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD40
-rw-r--r--install28
-rw-r--r--nano-node.service15
-rw-r--r--nanowallet.desktop11
-rw-r--r--nanowallet128.pngbin0 -> 2621 bytes
-rw-r--r--raiblocks.desktop10
-rw-r--r--raiblocks.service15
8 files changed, 83 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7ea23df3258..3d37aa8ca3bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Sat Jan 20 18:51:47 UTC 2018
-pkgbase = raiblocks-git
- pkgdesc = RaiBlocks is a cryptocurrency designed from the ground up for scalable instant transactions and zero transaction fees.
- pkgver = 9.0.r136.g92169180
+# Thu Feb 15 23:40:41 UTC 2018
+pkgbase = nanocurrency-git
+ pkgdesc = Nano (formerly RaiBlocks) is a cryptocurrency designed from the ground up for scalable instant transactions and zero transaction fees.
+ pkgver = 10.0.r1.g4e4bcf8d
pkgrel = 1
- url = http://raiblocks.com/
+ url = https://nano.org/
install = install
arch = i686
arch = x86_64
@@ -14,22 +14,26 @@ pkgbase = raiblocks-git
depends = boost>=1.66.0
depends = boost-libs>=1.66.0
provides = raiblocks
- source = raiblocks.desktop
- source = raiblocks128.png
- source = raiblocks.service
- source = git+https://github.com/clemahieu/raiblocks.git
+ provides = nanocurrency
+ conflicts = raiblocks
+ conflicts = raiblocks-git,
+ conflicts = raiblocks-node-git
+ source = nanowallet.desktop
+ source = nanowallet128.png
+ source = nano-node.service
+ source = git+https://github.com/nanocurrency/raiblocks.git
source = git+https://github.com/weidai11/cryptopp.git
source = git+https://github.com/clemahieu/lmdb.git
source = git+https://github.com/miniupnp/miniupnp.git
source = git+https://github.com/clemahieu/phc-winner-argon2.git
- sha256sums = 74b9bc75c3d5596603e54e2553ff69d367f384789c7565437a72a64dc22f0fdd
- sha256sums = 7e08e2b6d50638fb1438c746da78defc49ef317ee8ffa6feeb52635a976a0ea9
- sha256sums = 53ed2e7cf24c02172e3e804dd8689674867d82ca21b7d03be590d7a9b3a9c8bb
+ sha256sums = 6b824bfd5a9f2c1cd8d6a30f858a7bdc7813a448f4894a151da035dac5af2f91
+ sha256sums = 27179351dbc3e000d54b5b13f0c2326b4c4bd06e93b1d0b2ea1849609aeadc2e
+ sha256sums = c219c91db98f33097e7d96ef0f0c95e4b9d6226ac2ab90e30be7f955c43bfa35
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
-pkgname = raiblocks-git
+pkgname = nanocurrency-git
diff --git a/PKGBUILD b/PKGBUILD
index f1bcff96fd64..debb45cfeda6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,32 @@
-pkgname=raiblocks-git
-pkgver=9.0.r136.g92169180
+pkgname=nanocurrency-git
+pkgver=10.0.r1.g4e4bcf8d
pkgrel=1
-pkgdesc="RaiBlocks is a cryptocurrency designed from the ground up for scalable instant transactions and zero transaction fees."
+pkgdesc="Nano (formerly RaiBlocks) is a cryptocurrency designed from the ground up for scalable instant transactions and zero transaction fees."
arch=('i686' 'x86_64')
-url="http://raiblocks.com/"
+url="https://nano.org/"
license=('BSD 2-clause')
makedepends=('cmake')
depends=('qt5-base' 'boost>=1.66.0' 'boost-libs>=1.66.0')
-provides=(raiblocks)
+provides=(raiblocks nanocurrency)
+conflicts=("raiblocks" "raiblocks-git", "raiblocks-node-git")
install=install
pkgver() {
cd "raiblocks"
git describe --long --tags | sed 's/^[vV]//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-source=(raiblocks.desktop
- raiblocks128.png
- raiblocks.service
- git+https://github.com/clemahieu/raiblocks.git
+source=(nanowallet.desktop
+ nanowallet128.png
+ nano-node.service
+ git+https://github.com/nanocurrency/raiblocks.git
git+https://github.com/weidai11/cryptopp.git
git+https://github.com/clemahieu/lmdb.git
git+https://github.com/miniupnp/miniupnp.git
git+https://github.com/clemahieu/phc-winner-argon2.git)
-sha256sums=('74b9bc75c3d5596603e54e2553ff69d367f384789c7565437a72a64dc22f0fdd'
- '7e08e2b6d50638fb1438c746da78defc49ef317ee8ffa6feeb52635a976a0ea9'
- '53ed2e7cf24c02172e3e804dd8689674867d82ca21b7d03be590d7a9b3a9c8bb'
+sha256sums=('6b824bfd5a9f2c1cd8d6a30f858a7bdc7813a448f4894a151da035dac5af2f91'
+ '27179351dbc3e000d54b5b13f0c2326b4c4bd06e93b1d0b2ea1849609aeadc2e'
+ 'c219c91db98f33097e7d96ef0f0c95e4b9d6226ac2ab90e30be7f955c43bfa35'
'SKIP'
'SKIP'
'SKIP'
@@ -64,7 +65,7 @@ prepare() {
build() {
cd "$srcdir/raiblocks"
- make rai_wallet
+ make nano_wallet
make rai_node
make rai_lib
}
@@ -72,14 +73,19 @@ build() {
package() {
cd "$srcdir/raiblocks"
- install -Dm755 rai_wallet "$pkgdir"/usr/bin/rai_wallet
+ install -Dm755 nano_wallet "$pkgdir"/usr/bin/nano_wallet
+ ln -s /usr/bin/nano_wallet "$pkgdir"/usr/bin/rai_wallet
install -Dm755 rai_node "$pkgdir"/usr/bin/rai_node
+ ln -s /usr/bin/rai_node "$pkgdir"/usr/bin/nano_node
install -Dm644 librai_lib.so "$pkgdir"/usr/lib/librai_lib.so
+ ln -s /usr/lib/librai_lib.so "$pkgdir"/usr/lib/libnano_lib.so
- install -Dm644 "$srcdir"/raiblocks128.png "$pkgdir"/usr/share/pixmaps/raiblocks128.png
- install -Dm644 "$srcdir"/raiblocks.desktop "$pkgdir"/usr/share/applications/raiblocks.desktop
+ install -Dm644 "$srcdir"/nanowallet128.png "$pkgdir"/usr/share/pixmaps/nanowallet128.png
+ install -Dm644 "$srcdir"/nanowallet.desktop "$pkgdir"/usr/share/applications/nanowallet.desktop
+ #ln -s /usr/share/applications/nanowallet.desktop "$pkgdir"/usr/lib/systemd/system/raiblocks.service
- install -Dm644 "$srcdir"/raiblocks.service "$pkgdir"/usr/lib/systemd/system/raiblocks-node.service
+ install -Dm644 "$srcdir"/nano-node.service "$pkgdir"/usr/lib/systemd/system/nano-node.service
+ ln -s /usr/lib/systemd/system/nano-node.service "$pkgdir"/usr/lib/systemd/system/raiblocks-node.service
}
# vim:set ts=2 sw=2 et:
diff --git a/install b/install
index 4382aba03c36..d11787f8bd45 100644
--- a/install
+++ b/install
@@ -1,16 +1,22 @@
-create_user() {
- getent passwd raiblocks &>/dev/null || {
- echo -n ">>> Creating raiblocks service user... "
- useradd --system --user-group -m --home /var/lib/raiblocks raiblocks
- echo "done"
- } # NOTE: we do not autoremove user due to security concerns (Arch policy)
- #chown raiblocks:raiblocks /var/lib/raiblocks
+create_or_update_user() {
+ if getent passwd raiblocks &>/dev/null; then
+ echo -n ">>> Updating nano-node service user from raiblocks... "
+ usermod -l nano-node -m -d /var/lib/nano-node raiblocks
+ groupmod -n nano-node raiblocks
+ echo "done. Data has been moved to /var/lib/nano-node"
+ else
+ getent passwd nano-node &>/dev/null || {
+ echo -n ">>> Creating nano-node service user... "
+ useradd --system --user-group -m --home /var/lib/nano-node nano-node
+ echo "done"
+ } # NOTE: we do not autoremove user due to security concerns (Arch policy)
+ #chown nano-node:nano-node /var/lib/nano-node
+ fi
}
-
post_install() {
- create_user
+ create_or_update_user
}
post_upgrade() {
- create_user
-} \ No newline at end of file
+ create_or_update_user
+}
diff --git a/nano-node.service b/nano-node.service
new file mode 100644
index 000000000000..c442556f9e4e
--- /dev/null
+++ b/nano-node.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Nano Cryptocurrency Node
+After=network.target
+
+[Service]
+User=nano-node
+Group=nano-node
+WorkingDirectory=~
+RuntimeDirectory=nano-node
+
+Type=simple
+ExecStart=/usr/bin/nano_node --data_path /var/lib/nano-node --daemon
+
+[Install]
+WantedBy=multi-user.target
diff --git a/nanowallet.desktop b/nanowallet.desktop
new file mode 100644
index 000000000000..b8c4c97f49a5
--- /dev/null
+++ b/nanowallet.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Nano Wallet
+Comment=The scalable, fast, zero-fee cryptocurrency
+Keywords=raiblocks
+Exec=nano_wallet %u
+Terminal=false
+Type=Application
+Icon=nanowallet128
+MimeType=x-scheme-handler/xrb;
+Categories=Office;Finance; \ No newline at end of file
diff --git a/nanowallet128.png b/nanowallet128.png
new file mode 100644
index 000000000000..7c0098c15045
--- /dev/null
+++ b/nanowallet128.png
Binary files differ
diff --git a/raiblocks.desktop b/raiblocks.desktop
deleted file mode 100644
index 52de42db3204..000000000000
--- a/raiblocks.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Name=RaiBlocks Wallet
-Comment=RaiBlocks, the scalable, fast, zero-fee cryptocurrency.
-Exec=rai_wallet %u
-Terminal=false
-Type=Application
-Icon=raiblocks128
-MimeType=x-scheme-handler/xrb;
-Categories=Office;Finance; \ No newline at end of file
diff --git a/raiblocks.service b/raiblocks.service
deleted file mode 100644
index d579e348375a..000000000000
--- a/raiblocks.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=Raiblocks Node
-After=network.target
-
-[Service]
-User=raiblocks
-Group=raiblocks
-WorkingDirectory=~
-RuntimeDirectory=raiblocks
-
-Type=simple
-ExecStart=/usr/bin/rai_node --data_path /var/lib/raiblocks --daemon
-
-[Install]
-WantedBy=multi-user.target