summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD59
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9cbe505fb59d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Thu Dec 14 16:30:32 UTC 2017
+pkgbase = raiblocks-git
+ pkgdesc = RaiBlocks is a cryptocurrency designed from the ground up for scalable instant transactions and zero transaction fees.
+ pkgver = 8.0.r123.g2db8063b
+ pkgrel = 1
+ url = http://raiblocks.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt5
+ depends = boost
+ depends = boost-libs
+ provides = raiblocks
+ source = git+https://github.com/clemahieu/raiblocks.git
+ source = git+https://github.com/boostorg/beast.git
+ source = git+https://github.com/weidai11/cryptopp.git
+ source = git+https://github.com/LMDB/lmdb.git
+ source = git+https://github.com/miniupnp/miniupnp.git
+ source = git+https://github.com/clemahieu/phc-winner-argon2.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = raiblocks-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..04323110f7ac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+src/
+pkg/
+beast/
+cryptopp/
+lmdb/
+miniupnp/
+phc-winner-argon2/
+raiblocks/
+*.pkg.* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..163ba26675d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+pkgname=raiblocks-git
+pkgver=8.0.r123.g2db8063b
+pkgrel=1
+pkgdesc="RaiBlocks is a cryptocurrency designed from the ground up for scalable instant transactions and zero transaction fees."
+arch=('i686' 'x86_64')
+url="http://raiblocks.com/"
+license=('GPL')
+depends=('qt5' 'boost' 'boost-libs')
+provides=(raiblocks)
+pkgver() {
+ cd "raiblocks"
+ git describe --long --tags | sed 's/^[vV]//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+source=(git+https://github.com/clemahieu/raiblocks.git
+ git+https://github.com/boostorg/beast.git
+ git+https://github.com/weidai11/cryptopp.git
+ git+https://github.com/LMDB/lmdb.git
+ git+https://github.com/miniupnp/miniupnp.git
+ git+https://github.com/clemahieu/phc-winner-argon2.git)
+noextract=()
+md5sums=(SKIP
+ SKIP
+ SKIP
+ SKIP
+ SKIP
+ SKIP)
+
+prepare() {
+ cd "$srcdir/raiblocks"
+
+ git submodule init
+
+ git config submodule.beast.url $srcdir/beast
+ git config submodule.cryptopp.url $srcdir/cryptopp
+ git config submodule.lmdb.url $srcdir/lmdb
+ git config submodule.miniupnp.url $srcdir/miniupnp
+ git config submodule.phc-winner-argon2.url $srcdir/phc-winner-argon2
+
+ rm *.tar.gz || true 2>/dev/null
+
+ git submodule update
+ cmake cmake -D RAIBLOCKS_GUI=ON ./
+}
+
+build() {
+ cd "$srcdir/raiblocks"
+ make rai_wallet
+
+}
+
+package() {
+ cd "$srcdir/raiblocks"
+
+ install -Dm755 rai_wallet "$pkgdir"/usr/bin/rai_wallet
+ install -Dm755 rai_node "$pkgdir"/usr/bin/rai_node
+}
+
+# vim:set ts=2 sw=2 et: