summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1b02425709a..70995a25b6e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
# Maintainer: Toni Uhlig <matzeton@googlemail.com>
pkgname=ndpi-git
-pkgver=r3017.0f8a9948
+pkgver=3008.4bff5957
pkgrel=1
pkgdesc="Open and Extensible GPLv3 Deep Packet Inspection Library"
arch=('i686' 'x86_64')
url="http://www.ntop.org/products/ndpi/"
license=('GPL3')
+requires=('libmaxminddb', 'libgcrypt')
provides=('ndpi')
conflicts=('ndpi')
source=("${pkgname%-git}::git+https://github.com/ntop/nDPI.git#branch=dev")
@@ -19,21 +20,16 @@ pkgver() {
}
build() {
- cd "${srcdir}/${pkgname%-git}"
+ cd ndpi
CPPFLAGS="${CPPFLAGS} ${CFLAGS}"
./autogen.sh
- ./configure --prefix=/usr \
- --with-pic \
- --includedir=/usr/include \
- --libdir=/usr/lib
+ ./configure --prefix=/usr --with-pic --includedir=/usr/include --libdir=/usr/lib
make
}
package() {
- cd "${srcdir}/${pkgname%-git}"
- make DESTDIR="${pkgdir}" install
- ln -sf /usr/include/ndpi \
- "${pkgdir}/usr/include/libndpi"
+ cd ndpi
+ make DESTDIR="${pkgdir}/" install
}
sha256sums=('SKIP')