summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD50
-rw-r--r--bindir.patch16
-rw-r--r--config.patch12
-rw-r--r--neard.service10
5 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f7e47c6590e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by makepkg 4.2.1
+# Mon Apr 13 15:14:10 UTC 2015
+pkgbase = neard
+ pkgdesc = Intel's Near Field Communication manager
+ pkgver = 0.15
+ pkgrel = 1
+ url = https://01.org/linux-nfc/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = automake
+ makedepends = autoconf>=2.60
+ makedepends = libtool
+ depends = glibc
+ depends = dbus>=1.2
+ depends = libnl
+ depends = glib2>=2.28
+ backup = etc/neard/main.conf
+ source = http://git.kernel.org/cgit/network/nfc/neard.git/snapshot/neard-0.15.tar.gz
+ source = bindir.patch
+ source = config.patch
+ source = neard.service
+ md5sums = 13446cb7502b7a97447778f62620bfdf
+ md5sums = 5ab4e8d3ec2b8dd1d591483b072b07b4
+ md5sums = 1e3cfed20a3dbdb7ee9d0946e1c8dc81
+ md5sums = 3968d529bd6d1604f7e2ee3ce18fd3b6
+
+pkgname = neard
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b7be5fc0b39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Rupus Reinefjord <rupus@kltrst.se>
+# Contributor: Dmytro Bagrii <dimich.dmb@gmail.com>
+
+pkgname=neard
+pkgver=0.15
+pkgrel=1
+pkgdesc="Intel's Near Field Communication manager"
+arch=('i686' 'x86_64')
+url="https://01.org/linux-nfc/"
+license=('GPL2')
+depends=('glibc' 'dbus>=1.2' 'libnl' 'glib2>=2.28')
+makedepends=('automake' 'autoconf>=2.60' 'libtool')
+backup=(etc/neard/main.conf)
+source=(http://git.kernel.org/cgit/network/nfc/neard.git/snapshot/$pkgname-$pkgver.tar.gz
+ bindir.patch
+ config.patch
+ neard.service)
+md5sums=('13446cb7502b7a97447778f62620bfdf'
+ '5ab4e8d3ec2b8dd1d591483b072b07b4'
+ '1e3cfed20a3dbdb7ee9d0946e1c8dc81'
+ '3968d529bd6d1604f7e2ee3ce18fd3b6')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ patch -p1 -i $srcdir/bindir.patch
+
+ patch -p1 -i $srcdir/config.patch
+
+ ./bootstrap && \
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-debug \
+ --enable-tools
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+
+ install -D -m644 "${srcdir}/neard.service" \
+ "${pkgdir}/usr/lib/systemd/system/neard.service"
+
+ install -D -m644 "${srcdir}/$pkgname-$pkgver/src/main.conf" \
+ "${pkgdir}/etc/neard/main.conf"
+}
diff --git a/bindir.patch b/bindir.patch
new file mode 100644
index 000000000000..4bf173e8eaa8
--- /dev/null
+++ b/bindir.patch
@@ -0,0 +1,16 @@
+diff -aur neard-0.15.orig/Makefile.am neard-0.15.new/Makefile.am
+--- neard-0.15.orig/Makefile.am 2014-12-08 00:20:48.000000000 +0100
++++ neard-0.15.new/Makefile.am 2015-04-13 17:01:51.164776838 +0200
+@@ -31,10 +31,10 @@
+ builtin_cflags =
+ builtin_libadd =
+
+-bin_PROGRAMS =
++bin_PROGRAMS = src/neard
+
+ pkglibexecdir = ${libexecdir}/nfc
+-pkglibexec_PROGRAMS = src/neard
++pkglibexec_PROGRAMS =
+
+ src_neard_SOURCES = $(gdbus_sources) $(gweb_sources) $(builtin_sources) \
+ src/main.c src/error.c src/near.h src/log.c \
diff --git a/config.patch b/config.patch
new file mode 100644
index 000000000000..8141bdc5707b
--- /dev/null
+++ b/config.patch
@@ -0,0 +1,12 @@
+diff -aur neard-0.15.orig/src/main.conf neard-0.15.new/src/main.conf
+--- neard-0.15.orig/src/main.conf 2014-12-08 00:20:48.000000000 +0100
++++ neard-0.15.new/src/main.conf 2015-04-13 17:06:33.953061915 +0200
+@@ -4,7 +4,7 @@
+ # Constant polling will automatically trigger a new
+ # polling loop whenever a tag or a device is no longer
+ # in the RF field.
+-ConstantPoll = true
++ConstantPoll = false
+
+ # Automatically turn an adapter on when being discovered.
+ # Default value is false.
diff --git a/neard.service b/neard.service
new file mode 100644
index 000000000000..6cc65bd43ac4
--- /dev/null
+++ b/neard.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Near Field Communication Daemon
+Documentation=man:neard(8)
+
+[Service]
+Type=forking
+ExecStart=/usr/bin/neard
+
+[Install]
+WantedBy=multi-user.target