summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md44
-rw-r--r--PKGBUILD4
3 files changed, 48 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 198dab87cac6..3cbd47039c63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = neovim-bqf
pkgdesc = Better quickfix window in Neovim
- pkgver = 0.3.3
+ pkgver = 0.9.9
pkgrel = 1
url = https://github.com/kevinhwang91/nvim-bqf
changelog = CHANGELOG.md
@@ -10,7 +10,7 @@ pkgbase = neovim-bqf
depends = neovim
optdepends = fzf
optdepends = neovim-tree-sitter
- source = neovim-bqf-0.3.3.tar.gz::https://github.com/kevinhwang91/nvim-bqf/archive/v0.3.3.tar.gz
- sha256sums = 7b7ddf2c38e23d0b6ad941350ba0cb44ae41fb5503944fe5e80f33ce9044c963
+ source = neovim-bqf-0.9.9.tar.gz::https://github.com/kevinhwang91/nvim-bqf/archive/v0.9.9.tar.gz
+ sha256sums = a89aaa6bbca75727b72f10b71e58ed531070a1e69ea6aaf46b77378a45ef8d3e
pkgname = neovim-bqf
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 812ff6f3308b..a607234ad797 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,47 @@
# Changelog
+## [0.9.9] - 2022-08-25
+
+### Bug Fixes
+
+#### MagicWin
+
+- Qf at top/above should check botline
+
+#### FZF
+
+- Render highlighting is wrong for source syntax
+- Handle empty str for capturing iskeyword (#64)
+
+#### Preview
+
+- Should pass srcBufnr to nvim-treesitter (#63)
+- Get winline() from quickfix win
+- Close preview window if qf buffer is hidden (#70)
+
+#### Qfwin
+
+- Qf window Can't drop empty buffer name
+- Can't close location if previous window is invalid
+
+#### Miscellaneous
+
+- Debounce args should be changed
+- Upstream changed the C type in nightly
+- Can't split a window while closing another in nightly
+
+### Features
+
+#### Preview
+
+- Support mouse scroll and double click for preview window
+
+### Performance
+
+#### Preview
+
+- Prefer to use loaded buffer filetype
+
## [0.3.3] - 2022-04-16
### Bug Fixes
@@ -78,7 +120,7 @@
- No error for wiped buffer while jumping
- Quickfixtextfunc field in list should be supported
- Avoid extra error while switching list
-- Dispose throwed a error from nvim_buf_del_keymap()
+- Dispose threw a error from nvim_buf_del_keymap()
### Documentation
diff --git a/PKGBUILD b/PKGBUILD
index 796a742eef2d..a7be445a1f26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=neovim-bqf
-pkgver=0.3.3
+pkgver=0.9.9
pkgrel=1
pkgdesc="Better quickfix window in Neovim"
arch=('any')
@@ -12,7 +12,7 @@ depends=('neovim')
optdepends=('fzf' 'neovim-tree-sitter')
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('7b7ddf2c38e23d0b6ad941350ba0cb44ae41fb5503944fe5e80f33ce9044c963')
+sha256sums=('a89aaa6bbca75727b72f10b71e58ed531070a1e69ea6aaf46b77378a45ef8d3e')
package() {
cd "nvim-bqf-$pkgver"