summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
-rw-r--r--cmp.install9
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d40d674860c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = neovim-cmp
+ pkgdesc = Autocompletion plugin for Neovim
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/hrsh7th/nvim-cmp
+ install = cmp.install
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ depends = neovim
+ optdepends = neovim-cmp-nvim-lsp: source for Neovim builtin LSP client
+ optdepends = neovim-cmp-buffer: buffer autocompletion
+ optdepends = neovim-cmp-path: path autocompletion
+ optdepends = neovim-cmp-emoji: emoji autocompletion
+ optdepends = neovim-cmp-latex-symbols: LaTeX symbol autocompletion
+ optdepends = neovim-cmp-omni: omnifunc autocompletion
+ optdepends = neovim-cmp-vsnip: vsnip autocompletion
+ source = neovim-cmp-0.0.1.tar.gz::https://github.com/hrsh7th/nvim-cmp/archive/v0.0.1.tar.gz
+ sha256sums = bf09327702142ad46ee0344ea50dea7e249f8bfae728592a4ea8a2bc6ca8f5d6
+
+pkgname = neovim-cmp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b3f79e8a43d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-cmp
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Autocompletion plugin for Neovim"
+arch=('any')
+url="https://github.com/hrsh7th/nvim-cmp"
+license=('MIT')
+groups=('neovim-plugins')
+depends=('neovim')
+optdepends=(
+ 'neovim-cmp-nvim-lsp: source for Neovim builtin LSP client'
+ 'neovim-cmp-buffer: buffer autocompletion'
+ 'neovim-cmp-path: path autocompletion'
+ 'neovim-cmp-emoji: emoji autocompletion'
+ 'neovim-cmp-latex-symbols: LaTeX symbol autocompletion'
+ 'neovim-cmp-omni: omnifunc autocompletion'
+ 'neovim-cmp-vsnip: vsnip autocompletion')
+install=cmp.install
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('bf09327702142ad46ee0344ea50dea7e249f8bfae728592a4ea8a2bc6ca8f5d6')
+
+package() {
+ cd "nvim-cmp-$pkgver"
+ find autoload lua plugin \
+ -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/nvim/runtime/pack/dist/start/$pkgname/{}" \;
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/cmp.install b/cmp.install
new file mode 100644
index 000000000000..8002fda9c9a0
--- /dev/null
+++ b/cmp.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-cmp/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}