summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD45
-rw-r--r--cmp_luasnip.install9
3 files changed, 34 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc4a6e8dd40a..44239b869606 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
pkgbase = neovim-cmp_luasnip-git
pkgdesc = nvim-cmp source for LuaSnip
- pkgver = r32.9674906
+ pkgver = r66.05a9ab2
pkgrel = 1
url = https://github.com/saadparwaiz1/cmp_luasnip
- install = cmp_luasnip.install
arch = any
- groups = neovim-plugin
- license = custom:unknown
+ groups = neovim-plugins
+ license = Apache
makedepends = git
- depends = neovim-cmp
- depends = neovim-luasnip
- provides = neovim-cmp_luasnip
- conflicts = neovim-cmp_luasnip
- source = neovim-cmp_luasnip-git::git+https://github.com/saadparwaiz1/cmp_luasnip
- md5sums = SKIP
+ source = git+https://github.com/saadparwaiz1/cmp_luasnip.git
+ sha512sums = SKIP
pkgname = neovim-cmp_luasnip-git
+ depends = neovim
diff --git a/PKGBUILD b/PKGBUILD
index 9b7b3d8c9a7b..4d3070b21b31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,39 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
-
pkgname=neovim-cmp_luasnip-git
-pkgver=r32.9674906
+pkgver=r66.05a9ab2
pkgrel=1
pkgdesc="nvim-cmp source for LuaSnip"
arch=('any')
url="https://github.com/saadparwaiz1/cmp_luasnip"
-license=('custom:unknown')
-groups=('neovim-plugin')
-depends=('neovim-cmp' 'neovim-luasnip')
-makedepends=('git')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-install=cmp_luasnip.install
-source=("$pkgname::git+$url")
-md5sums=('SKIP')
+license=('Apache')
+
+groups=(
+ 'neovim-plugins'
+)
+
+makedepends=(
+ 'git'
+)
+
+source=(
+ "git+https://github.com/saadparwaiz1/cmp_luasnip.git"
+)
+
+sha512sums=(
+ 'SKIP'
+)
pkgver() {
- cd "$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd cmp_luasnip
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "$pkgname"
- find after lua -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/pack/dist/start/$pkgname/{}" \;
- install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ depends+=(
+ 'neovim'
+ )
+
+ cd cmp_luasnip
+ find after lua -type f -exec install -D -m644 '{}' "$pkgdir/usr/share/nvim/site/pack/dist/start/${pkgname}/{}" \;
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}
diff --git a/cmp_luasnip.install b/cmp_luasnip.install
deleted file mode 100644
index 778d63df1cd6..000000000000
--- a/cmp_luasnip.install
+++ /dev/null
@@ -1,9 +0,0 @@
-post_install() {
- echo ':: This plugin requires manual setup.'
- echo ':: Consult upstream documentation for more information.'
- echo ':: A copy has been installed under /usr/share/doc/neovim-cmp_luasnip-git/README.md for your reference.'
-}
-
-post_remove() {
- echo ':: Remember to remove all references to this plugin from your init scripts.'
-}