summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f284afe3a96
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = neovim-deus-git
+ pkgdesc = A better color scheme for the late night coder -- Neovim port with treesitter support
+ pkgver = r8.04761b9
+ pkgrel = 1
+ url = https://github.com/theniceboy/nvim-deus
+ arch = any
+ groups = neovim-plugins
+ license = GPL3
+ makedepends = git
+ depends = neovim>=0.5.0
+ provides = neovim-deus
+ provides = vim-deus
+ conflicts = neovim-deus
+ conflicts = vim-deus
+ source = neovim-deus-git::git+https://github.com/theniceboy/nvim-deus
+ sha256sums = SKIP
+
+pkgname = neovim-deus-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..539cfa9124f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+
+pkgname=neovim-deus-git
+pkgver=r8.04761b9
+pkgrel=1
+pkgdesc="A better color scheme for the late night coder -- Neovim port with treesitter support"
+arch=('any')
+url="https://github.com/theniceboy/nvim-deus"
+license=('GPL3')
+groups=('neovim-plugins')
+depends=('neovim>=0.5.0')
+makedepends=('git')
+provides=("${pkgname%-git}" 'vim-deus')
+conflicts=("${pkgname%-git}" 'vim-deus')
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find colors lua -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}