summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--diffview.install8
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a271bcc481e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = neovim-diffview-git
+ pkgdesc = Single tabpage interface for cycling through diffs for all modified files
+ pkgver = r44.e0ffb1c
+ pkgrel = 1
+ url = https://github.com/sindrets/diffview.nvim
+ install = diffview.install
+ arch = any
+ groups = neovim-plugins
+ license = GPL3
+ depends = neovim>=0.5
+ depends = git
+ optdepends = neovim-web-devicons
+ provides = neovim-diffview
+ conflicts = neovim-diffview
+ source = neovim-diffview-git::git+https://github.com/sindrets/diffview.nvim
+ md5sums = SKIP
+
+pkgname = neovim-diffview-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..551bb92fd081
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-diffview-git
+pkgver=r44.e0ffb1c
+pkgrel=1
+pkgdesc="Single tabpage interface for cycling through diffs for all modified files"
+arch=('any')
+url="https://github.com/sindrets/diffview.nvim"
+license=('GPL3')
+groups=('neovim-plugins')
+depends=('neovim>=0.5' 'git')
+optdepends=('neovim-web-devicons')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=diffview.install
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find doc lua plugin -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/diffview.install b/diffview.install
new file mode 100644
index 000000000000..7f9f44a7bb01
--- /dev/null
+++ b/diffview.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo ':: Please consult upstream documentation for information on how to manually set up this plugin.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-diffview-git/README.md for your convenience.'
+}
+
+post_remove() {
+ echo ":: Remember to remove all references to this plugin in your init scripts."
+}