summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD23
-rw-r--r--nvim-doc.install14
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be1a746561b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = neovim-indent-object
+ pkgdesc = Text objects based on indent levels
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = http://www.vim.org/scripts/script.php?script_id=3037
+ install = nvim-doc.install
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ depends = neovim
+ source = neovim-indent-object-1.1.2.tar.gz::https://github.com/michaeljsmith/vim-indent-object/tarball/1.1.2
+ sha256sums = 8fa0e3f117d666c28fe4ab7128096c056fe1cc2c3347e2d5da95eff92d96ca78
+
+pkgname = neovim-indent-object
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7123c0a23024
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+# package src/pkg archives, downloaded sources
+*.tar*
+*.tgz
+*.zip
+
+# signed sources
+*.asc
+*.sig
+
+# subfolders, e.g. source or built package trees, vcs
+*/**/
+!neovim-plugins/*
+# backup files
+*~
+*.bak
+pkg
+src
+*xpi
+*tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ec813593334
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainter: Joost Bremmer <toost.b@gmail.com>
+# Contributor: Daniel Micay <danielmicay@gmail.com>
+# Contributor: vae77 <fernandogrd@yahoo.com.br>
+
+pkgname=neovim-indent-object
+pkgver=1.1.2
+pkgrel=1
+pkgdesc='Text objects based on indent levels'
+arch=(any)
+url='http://www.vim.org/scripts/script.php?script_id=3037'
+license=(MIT)
+groups=('neovim-plugins')
+depends=(neovim)
+install=nvim-doc.install
+source=("$pkgname-${pkgver}.tar.gz::https://github.com/michaeljsmith/${pkgname#neo}/tarball/$pkgver")
+sha256sums=('8fa0e3f117d666c28fe4ab7128096c056fe1cc2c3347e2d5da95eff92d96ca78')
+
+package() {
+ cd "$srcdir/michaeljsmith-${pkgname#neo}-eb911bc/"
+ local installpath="$pkgdir/usr/share/nvim/runtime"
+ install -dv "$installpath"
+ cp -r --no-preserve=owner * "$installpath"
+}
diff --git a/nvim-doc.install b/nvim-doc.install
new file mode 100644
index 000000000000..79795d84c37b
--- /dev/null
+++ b/nvim-doc.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo -n "Updating neovim help tags..."
+ /usr/bin/nvim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/nvim/runtime/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}