summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore19
-rw-r--r--LICENSE7
-rw-r--r--PKGBUILD33
-rw-r--r--nvim-doc.install14
5 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5dbda7255ae0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neovim-project
+ pkgdesc = Organize and navigate projects of files (like an ide/buffer explorer)
+ pkgver = 1.4.1
+ pkgrel = 1
+ url = http://www.vim.org/scripts/script.php?script_id=69
+ install = nvim-doc.install
+ arch = any
+ groups = neovim-plugins
+ license = custom
+ depends = neovim
+ source = neovim-project.tar.gz::http://www.vim.org/scripts/download_script.php?src_id=6273
+ source = LICENSE
+ sha256sums = 6e0c60cb2782d8232182124b0b617fdb6f1e1fcf0259273ce717940976d0b097
+ sha256sums = e5cf201d8687c2b7752dc10a24810ec29f7bec1dfab0b3f03cde3e9909cddc0f
+
+pkgname = neovim-project
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7123c0a23024
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+# package src/pkg archives, downloaded sources
+*.tar*
+*.tgz
+*.zip
+
+# signed sources
+*.asc
+*.sig
+
+# subfolders, e.g. source or built package trees, vcs
+*/**/
+!neovim-plugins/*
+# backup files
+*~
+*.bak
+pkg
+src
+*xpi
+*tar*
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b136b66c12ca
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,7 @@
+"=============================================================================
+" File: project.vim
+" Author: Aric Blumer (Aric.Blumer at aricvim@charter.net)
+" Last Change: Fri 13 Oct 2006 09:47:08 AM EDT
+" Version: 1.4.1
+"=============================================================================
+" You may use this code in whatever way you see fit.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7187b601baf7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Joost Bremmer <toost.b@gmail.com>
+# Contributor: Aaron Griffin <aaron@archlinux.org>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=neovim-project
+pkgver=1.4.1
+_scriptid=6273
+pkgrel=1
+pkgdesc="Organize and navigate projects of files (like an ide/buffer explorer)"
+arch=('any')
+url="http://www.vim.org/scripts/script.php?script_id=69"
+license=('custom')
+depends=('neovim')
+groups=('neovim-plugins')
+install=nvim-doc.install
+source=("$pkgname.tar.gz::http://www.vim.org/scripts/download_script.php?src_id=$_scriptid"
+ 'LICENSE')
+sha256sums=('6e0c60cb2782d8232182124b0b617fdb6f1e1fcf0259273ce717940976d0b097'
+ 'e5cf201d8687c2b7752dc10a24810ec29f7bec1dfab0b3f03cde3e9909cddc0f')
+
+package() {
+ cd ${srcdir}
+
+ installpath="${pkgdir}/usr/share/nvim/runtime"
+
+ install -D -m644 doc/project.txt \
+ $installpath/doc/project.txt
+ install -D -m644 plugin/project.vim \
+ $installpath/plugin/project.vim
+ install -D -m644 LICENSE \
+ ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+# vim: set ts=2 sw=2 et:
diff --git a/nvim-doc.install b/nvim-doc.install
new file mode 100644
index 000000000000..79795d84c37b
--- /dev/null
+++ b/nvim-doc.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo -n "Updating neovim help tags..."
+ /usr/bin/nvim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/nvim/runtime/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}