summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
-rw-r--r--project.install9
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..740a98a65711
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = neovim-project-git
+ pkgdesc = Project management plugin
+ pkgver = r76.7b23fb7
+ pkgrel = 1
+ url = https://github.com/ahmedkhalf/project.nvim
+ install = project.install
+ arch = any
+ groups = neovim-plugins
+ license = Apache
+ makedepends = git
+ depends = neovim>=0.5.0
+ optdepends = neovim-telescope: builtin integration
+ provides = neovim-project
+ conflicts = neovim-project
+ source = neovim-project-git::git+https://github.com/ahmedkhalf/project.nvim
+ md5sums = SKIP
+
+pkgname = neovim-project-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0be4ba8e353
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-project-git
+pkgver=r76.7b23fb7
+pkgrel=1
+pkgdesc="Project management plugin"
+arch=('any')
+url="https://github.com/ahmedkhalf/project.nvim"
+license=('Apache')
+groups=('neovim-plugins')
+depends=('neovim>=0.5.0')
+optdepends=('neovim-telescope: builtin integration')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=project.install
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find lua -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/project.install b/project.install
new file mode 100644
index 000000000000..79655800053f
--- /dev/null
+++ b/project.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-project-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}