summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD41
-rw-r--r--substrata.install9
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4770a3214711
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = neovim-substrata-git
+ pkgdesc = Cold, dark theme ported to Lua
+ pkgver = r40.e1362be
+ pkgrel = 1
+ url = https://github.com/kvrohit/substrata.nvim
+ arch = any
+ license = unknown
+ makedepends = git
+ source = neovim-substrata-git::git+https://github.com/kvrohit/substrata.nvim
+ md5sums = SKIP
+
+pkgname = neovim-substrata-git
+ install = substrata.install
+ groups = neovim-plugins
+ depends = neovim
+ provides = neovim-substrata
+ conflicts = neovim-substrata
+ conflicts = vim-substrata
+
+pkgname = neovim-substrata-extras-git
+ pkgdesc = extras theme templates for substrata
+ provides = neovim-substrata-extras
+ conflicts = neovim-substrata-extras
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86b7ed809c00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=('neovim-substrata-git' 'neovim-substrata-extras-git')
+pkgver=r40.e1362be
+pkgrel=1
+pkgdesc="Cold, dark theme ported to Lua"
+arch=('any')
+url="https://github.com/kvrohit/substrata.nvim"
+license=('unknown')
+makedepends=('git')
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package_neovim-substrata-git() {
+ depends=('neovim')
+ groups=('neovim-plugins')
+ provides=("${pkgname%-git}")
+ conflicts=("${pkgname%-git}" 'vim-substrata')
+ install=substrata.install
+
+ cd "$pkgname"
+ find colors lua \
+ -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
+
+package_neovim-substrata-extras-git() {
+ pkgdesc="extras theme templates for substrata"
+ provides=("${pkgname%-git}")
+ conflicts=("${pkgname%-git}")
+
+ cd "$pkgbase/extras"
+ install -d "$pkgdir/usr/share/substrata/"
+ cp -a --no-preserve=ownership * "$pkgdir/usr/share/substrata/"
+}
diff --git a/substrata.install b/substrata.install
new file mode 100644
index 000000000000..a804791ec5e4
--- /dev/null
+++ b/substrata.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-substrata-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}