summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad3b6d2a2a19..e13a8dbfc3bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = neovim-surround-opt-git
- pkgdesc = Provides mappings to easily delete, change, and add paired "surroundings."
- pkgver = 109.5970688
+ pkgdesc = Add/change/delete surrounding delimiter pairs with ease.
+ pkgver = 215.10b20ca
pkgrel = 1
- url = https://github.com/tpope/vim-surround
+ url = https://github.com/kylechui/nvim-surround
arch = any
- license = custom:vim
+ license = MIT
makedepends = git
depends = neovim
- source = surround::git+https://github.com/tpope/vim-surround.git
+ source = surround::git+https://github.com/kylechui/nvim-surround.git
sha256sums = SKIP
pkgname = neovim-surround-opt-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e8386a418a26..06b6f1a007d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
pkgname=neovim-surround-opt-git
-pkgver=113.f51a26d
+pkgver=235.8f2af76
_pkgname=surround
pkgrel=1
-pkgdesc='Provides mappings to easily delete, change, and add paired "surroundings."'
+pkgdesc='Add/change/delete surrounding delimiter pairs with ease.'
arch=('any')
-url="https://github.com/tpope/vim-${_pkgname}"
-license=('custom:vim')
+url="https://github.com/kylechui/nvim-${_pkgname}"
+license=('MIT')
depends=('neovim')
makedepends=('git')
source=("${_pkgname}::git+${url}.git")
@@ -28,6 +28,8 @@ package() {
install -dvm755 "${pkgdir}/${_installpath}"
- cp -rvt "${pkgdir}/${_installpath}" doc plugin
+ cp -rvt "${pkgdir}/${_installpath}" doc lua queries
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}