summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed1e31311ee4..f0cf57c9db5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = neovim-ultisnips
pkgdesc = TextMate-style snippets for Neovim.
- pkgver = 3.1
+ pkgver = 3.2
pkgrel = 1
url = https://github.com/SirVer/ultisnips
install = nvim-doc.install
@@ -10,10 +10,9 @@ pkgbase = neovim-ultisnips
makedepends = git
depends = neovim
depends = python-neovim
- source = neovim-ultisnips-3.1.tar.gz::https://github.com/SirVer/ultisnips/archive/3.1.tar.gz
- source = git+https://github.com/honza/vim-snippets.git
- sha256sums = 32ea72d321f07755e878f640398c72f0a072e56a980a66bdc7bfb41ba85fa6e7
+ source = neovim-ultisnips-3.2.tar.gz::https://github.com/SirVer/ultisnips/archive/3.2.tar.gz
+ source = git+https://github.com/honza/vim-snippets.git#commit=2a4beefc7dfff8419f40f2672cfaaa726bdbff72
+ sha256sums = 550365cdf6bf030b9e5b77e511b4e6b1427660ea6a117c4b6bb77afcb950c4ce
sha256sums = SKIP
pkgname = neovim-ultisnips
-
diff --git a/PKGBUILD b/PKGBUILD
index 462672365317..4fdb538af441 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
pkgname=neovim-ultisnips
-pkgver=3.1
+pkgver=3.2
pkgrel=1
pkgdesc='TextMate-style snippets for Neovim.'
arch=('any')
@@ -13,17 +13,18 @@ depends=('neovim' 'python-neovim')
groups=('neovim-plugins')
install=nvim-doc.install
makedepends=('git')
+_commit=2a4beefc7dfff8419f40f2672cfaaa726bdbff72
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/SirVer/ultisnips/archive/${pkgver}.tar.gz"
- git+https://github.com/honza/vim-snippets.git)
-sha256sums=('32ea72d321f07755e878f640398c72f0a072e56a980a66bdc7bfb41ba85fa6e7'
+ git+https://github.com/honza/vim-snippets.git#commit=$_commit)
+sha256sums=('550365cdf6bf030b9e5b77e511b4e6b1427660ea6a117c4b6bb77afcb950c4ce'
'SKIP')
package() {
- cd "${srcdir}/ultisnips-$pkgver"
+ cd "${pkgname#neovim-}-$pkgver"
install -dm755 "$pkgdir/usr/share/nvim/runtime/"
cp -r -t "$pkgdir/usr/share/nvim/runtime/" pythonx after doc ftdetect autoload\
- ftplugin plugin syntax utils
+ ftplugin plugin syntax
cd "${srcdir}/vim-snippets"
@@ -31,7 +32,7 @@ package() {
cp -r -t "$pkgdir/usr/share/nvim/runtime/" UltiSnips autoload snippets
# compile .pyc and .pyo files (fixes FS#43121)
- find "${pkgdir}" -name '*.py' -exec python2 -mpy_compile {} +
- find "${pkgdir}" -name '*.py' -exec python2 -O -mpy_compile {} +
+ find "${pkgdir}" -name '*.py' -exec python -mpy_compile {} +
+ find "${pkgdir}" -name '*.py' -exec python -O -mpy_compile {} +
}
# vim: sw=2 ts=2 et: