summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD26
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..99a9a2670d67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = nesc
+ pkgdesc = A extension to the C programming language designed to embody the structuring concepts and execution model of TinyOS.
+ pkgver = 1.3.6
+ pkgrel = 1
+ url = https://github.com/tinyos/nesc/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = automake
+ makedepends = autoconf
+ depends = emacs
+ depends = gperf
+ depends = bison
+ depends = flex
+ depends = java-environment
+ options = !buildflags
+ source = https://github.com/tinyos/nesc/archive/v1.3.6.zip
+ md5sums = 985866de3e5fd1deb3648db2f1b06566
+
+pkgname = nesc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58957191ee20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Stefand Probst <s1probst@edu.aau.at>
+pkgname="nesc"
+pkgver=1.3.6
+pkgrel=1
+pkgdesc="A extension to the C programming language designed to embody the structuring concepts and execution model of TinyOS."
+arch=('i686' 'x86_64')
+url="https://github.com/tinyos/nesc/"
+license=('GPL2')
+depends=('emacs' 'gperf' 'bison' 'flex' 'java-environment')
+makedepends=('automake' 'autoconf')
+options=('!buildflags')
+source=("https://github.com/tinyos/$pkgname/archive/v$pkgver.zip")
+md5sums=('985866de3e5fd1deb3648db2f1b06566')
+
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./Bootstrap
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}