summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD35
-rwxr-xr-xgetnessus.sh52
-rw-r--r--maintainer_notes.txt18
5 files changed, 19 insertions, 103 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de032764a28f..6ba8904354e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
-# Generated by mksrcinfo v8
-# Thu Feb 15 15:46:21 UTC 2018
pkgbase = nessus
- pkgdesc = Vulnerability scanner
- pkgver = 7.0.2
+ pkgdesc = Nessus vulnerability scanner
+ pkgver = 7.1.3
pkgrel = 1
url = https://www.nessus.org
install = nessus.install
arch = x86_64
license = custom
depends = gnupg
+ source = Nessus-7.1.3-fc20.x86_64.rpm::https://gateway.ipfs.io/ipfs/QmSxr3yEsgP5JvnpyNtb7dfcvCJgqoxh7sDWV2fjPs8ZkZ
source = nessus.desktop
source = nessus.sh
source = LICENSE
- md5sums = 0bbf1879d13a1ddd2667eede1468e553
- md5sums = 388578bf980efe6e6d3f33fcc289543a
- md5sums = 8c5772ac63f97d94475fe03e80d6ba5c
- md5sums = 1db6df5a39009ace46c7ee40141ece1b
+ sha256sums = abbae32cee99762787e8bbdd009526d35551a27362191d93a292eb078d8c0b25
+ sha256sums = 8c5e82d609a7290c34cbfa5635012cb66820e4e2c1db2bf5808fc306fcefdc30
+ sha256sums = 9b8e2c15d86ce7b83806a27bd6685f009ad339f3ea52022b87a75fbd2802ec5a
+ sha256sums = 089073d03bf83e101b50da858348ace6bb2a553ce2249532d6f5d7ed29182dac
pkgname = nessus
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2aee660bb1c7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.rpm
+
diff --git a/PKGBUILD b/PKGBUILD
index 2807a4b86711..b41b4fbc6686 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,27 @@
-# Maintainer: MattWoelk
+# Maintainer: Kenneth Endfinger <kaendfinger@gmail.com>
+# Contributor: MattWoelk
# Contributor: xsmile <sascha_r gmx de>
-_retoken='.*<div id="timecheck" class="hidden">(\w+)<.*'
pkgname=nessus
-pkgver=7.0.2
+pkgver=7.1.3
pkgrel=1
-_filename="${pkgname^}-${pkgver}-fc20.x86_64.rpm"
-pkgdesc="Vulnerability scanner"
+pkgdesc="Nessus vulnerability scanner"
arch=('x86_64')
depends=('gnupg')
license=('custom')
url="https://www.nessus.org"
install=${pkgname}.install
-_gettoken() {
- token=$(curl -s https://www.tenable.com/products/nessus/select-your-operating-system#tos | \
- sed -nr "s/${_retoken}/\1/p")
-
- if [[ "$token" == "" ]]; then
- echo
- echo " -> Could not get the download token, '_retoken' might need an update"
- exit 1
- fi
-
- echo "$token"
-}
-_token=$(_gettoken)
-_pkgurl="https://downloads.nessus.org/nessus3dl.php?file=${_filename}&licence_accept=yes&t=${_token}"
-
-source=("${_filename}::${_pkgurl}"
+# Note: I had to use ipfs because I don't want to redistribute the file on a known server.
+source=("Nessus-7.1.3-fc20.x86_64.rpm::https://gateway.ipfs.io/ipfs/QmSxr3yEsgP5JvnpyNtb7dfcvCJgqoxh7sDWV2fjPs8ZkZ"
nessus.desktop
nessus.sh
LICENSE)
-md5sums=('0bbf1879d13a1ddd2667eede1468e553'
- '388578bf980efe6e6d3f33fcc289543a'
- '8c5772ac63f97d94475fe03e80d6ba5c'
- '1db6df5a39009ace46c7ee40141ece1b')
+sha256sums=('abbae32cee99762787e8bbdd009526d35551a27362191d93a292eb078d8c0b25'
+ '8c5e82d609a7290c34cbfa5635012cb66820e4e2c1db2bf5808fc306fcefdc30'
+ '9b8e2c15d86ce7b83806a27bd6685f009ad339f3ea52022b87a75fbd2802ec5a'
+ '089073d03bf83e101b50da858348ace6bb2a553ce2249532d6f5d7ed29182dac')
package() {
install -Dm755 $pkgname.sh "$pkgdir/etc/profile.d/$pkgname.sh"
diff --git a/getnessus.sh b/getnessus.sh
deleted file mode 100755
index 7b3e62ab0f86..000000000000
--- a/getnessus.sh
+++ /dev/null
@@ -1,52 +0,0 @@
-#!/bin/bash
-
-# Created by vendforce for the Matthew Woelk in the arch AUR
-# Nessusdownlader is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# Nessusdownlader is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-#### Wget https settings
-WGET_HSTS="--no-hsts"
-
-RELEASE=6.8.0
-
-echo -e "The Nessus downloader is temporarily broken due to an upstream change."
-echo -e "Please download Nessus from http://www.tenable.com/products/nessus/select-your-operating-system#tos"
-echo -e "Then put Nessus-$RELEASE-fc20.x86_64.rpm in the tmp folder for this package and run the installer again."
-exit
-
-
-
-
-
-echo -e "Downloading Nessus $RELEASE from downloads.nessus.org ... "
-
-if [ -f Nessus-$RELEASE-fc20.x86_64.rpm ] ; then
- echo -e "Local file already exists for Nessus $RELEASE. No need to re-download it."
- exit
-fi
-
-# These two lines disabled for now (hard-coded instead) because getting the ID this way is no longer working
-#ID=$(wget $WGET_HSTS -qO - /dev/null "https://downloads.nessus.org/nessus3dl.php?file=Nessus-$RELEASE-fc20.x86_64.rpm&licence_accept=yes" | grep "og:description" | cut -d= -f3 | sed -e 's/^"*//' | cut -d* -f1)
-#DOWNLOAD=$(wget $WGET_HSTS -O/dev/null -q "http://downloads.nessus.org/nessus3dl.php?file=Nessus-$RELEASE-fc20.x86_64.rpm&licence_accept=yes&t=$ID" && echo "exists" || echo "not exist")
-DOWNLOAD=$(wget $WGET_HSTS -O/dev/null -q "http://downloads.nessus.org/nessus3dl.php?file=Nessus-$RELEASE-fc20.x86_64.rpm&licence_accept=yes&t=39834650794bd3c9ec30dbb14d625b23" && echo "exists" || echo "not exist")
-http://downloads.nessus.org/nessus3dl.php?file=Nessus-6.8.0-fc20.x86_64.rpm&licence_accept=yes&t=39834650794bd3c9ec30dbb14d625b23
-
-echo "http://downloads.nessus.org/nessus3dl.php?file=Nessus-$RELEASE-fc20.x86_64.rpm&licence_accept=yes&t=39834650794bd3c9ec30dbb14d625b23"
-if [[ $DOWNLOAD == exists ]] ;then
- wget $WGET_HSTS -q "http://downloads.nessus.org/nessus3dl.php?file=Nessus-$RELEASE-fc20.x86_64.rpm&licence_accept=yes&t=$ID" -O Nessus-$RELEASE-fc20.x86_64.rpm
-else
- echo "... Downloading the file did not work properly. Get it manually from http://www.tenable.com/products/nessus/select-your-operating-system#tos"
- exit 1
-fi
-
-echo -e "... Download script has finished."
diff --git a/maintainer_notes.txt b/maintainer_notes.txt
deleted file mode 100644
index e85fcf53af2a..000000000000
--- a/maintainer_notes.txt
+++ /dev/null
@@ -1,18 +0,0 @@
-== Make Package ==
-
-In PKGBUILD, update pkgver to the new nessus version, and update the first md5sums to match
-the one on the website for Fedora.
-
-Then run `mksrcinfo`.
-
-Then edit .SRCINFO, removing the line that was just added about 'source = Nessus-...', but keeping the rest of the changes.
-If we kept that line, we'd be packaging the rpm with the package, but we want it instead to be downloaded.
-(For license reasons, or size reasons, or something...)
-
-Commit and push!
-
-
-== Test Locally ==
-
-You can do this using the `makepkg` command in the directory containing the PKGBUILD file
-`pacman -U /root/Download/packagename.tar.gz`