summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD65
3 files changed, 66 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 586d247ffe39..e71cb09728ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,29 @@
pkgbase = neural-amp-modeler-lv2-git
- pkgdesc = Neural Amp Modeler (NAM) LV2 Plugin
- pkgver = 0.1.3_r149.43fb036
+ pkgdesc = Neural Amp Modeler (NAM) LV2 plugin (git version)
+ pkgver = 0.1.3.r14.43fb036
pkgrel = 1
url = https://github.com/mikeoliphant/neural-amp-modeler-lv2
- arch = x86_64
arch = aarch64
- arch = riscv64
- arch = riscv
- arch = ppc
- arch = i386
+ arch = armv7h
arch = i686
arch = pentium4
- arch = arm
- arch = armv7h
- arch = armv6h
+ arch = riscv64
+ arch = riscv
+ arch = x86_64
license = GPL3
makedepends = git
makedepends = cmake
- makedepends = make
- makedepends = gcc
+ depends = gcc-libs
+ depends = glibc
provides = neural-amp-modeler-lv2
conflicts = neural-amp-modeler-lv2
- source = neural-amp-modeler-lv2-git::git+https://github.com/mikeoliphant/neural-amp-modeler-lv2.git
+ source = neural-amp-modeler-lv2::git+https://github.com/mikeoliphant/neural-amp-modeler-lv2.git
+ source = lv2::git+https://github.com/lv2/lv2.git
+ source = eigen::git+https://gitlab.com/libeigen/eigen.git
+ source = NeuralAmpModelerCore::git+https://github.com/mikeoliphant/NeuralAmpModelerCore.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = neural-amp-modeler-lv2-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e00793154358
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+eigen/
+lv2/
+NeuralAmpModelerCore/
+neural-amp-modeler-lv2/
+neural-amp-modeler-lv2-git-*.pkg.tar.*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 53c301b91587..896b4eebebb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,56 @@
# Maintainer: LekKit <github.com/LekKit>
+# Contributor: Christopher Arndt <aur -at -chrisarndt -dot- de>
-pkgname=neural-amp-modeler-lv2-git
-pkgver=0.1.3_r149.43fb036
+_pkgname=neural-amp-modeler-lv2
+pkgname=$_pkgname-git
+pkgver=0.1.3.r14.43fb036
pkgrel=1
-pkgdesc="Neural Amp Modeler (NAM) LV2 Plugin"
-arch=('x86_64' 'aarch64' 'riscv64' 'riscv' 'ppc' 'i386' 'i686' 'pentium4' 'arm' 'armv7h' 'armv6h')
-url="https://github.com/mikeoliphant/neural-amp-modeler-lv2"
-license=('GPL3')
-makedepends=('git' 'cmake' 'make' 'gcc')
-provides=('neural-amp-modeler-lv2')
-conflicts=('neural-amp-modeler-lv2')
-source=("$pkgname::git+https://github.com/mikeoliphant/neural-amp-modeler-lv2.git")
-sha256sums=('SKIP')
+pkgdesc='Neural Amp Modeler (NAM) LV2 plugin (git version)'
+arch=(aarch64 armv7h i686 pentium4 riscv64 riscv x86_64)
+url='https://github.com/mikeoliphant/neural-amp-modeler-lv2'
+license=(GPL3)
+depends=(gcc-libs glibc)
+makedepends=(git cmake)
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("$_pkgname::git+https://github.com/mikeoliphant/$_pkgname.git"
+ 'lv2::git+https://github.com/lv2/lv2.git'
+ 'eigen::git+https://gitlab.com/libeigen/eigen.git'
+ 'NeuralAmpModelerCore::git+https://github.com/mikeoliphant/NeuralAmpModelerCore.git'
+)
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
- cd $pkgname
- printf "0.1.3_r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd $_pkgname
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-\)g/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd $_pkgname
+ for submodule in lv2 eigen NeuralAmpModelerCore; do
+ git submodule init deps/$submodule
+ git submodule set-url deps/$submodule "$srcdir"/$submodule
+ git -c protocol.file.allow=always submodule update deps/$submodule
+ done
}
build() {
- cd $pkgname
- git submodule update --init --recursive --depth 1
- mkdir -p build
- cd build
- cmake .. -DCMAKE_BUILD_TYPE="Release"
- make -j
+ cmake -B $_pkgname-build -S $_pkgname \
+ -DCMAKE_BUILD_TYPE=Release
+ cmake --build $_pkgname-build --config Release -j $(nproc --ignore=1)
}
package() {
- mkdir -p $pkgdir/usr/lib/lv2/
- cp $pkgname/build/neural_amp_modeler.lv2 -r $pkgdir/usr/lib/lv2/
+ install -vDm 644 $_pkgname-build/neural_amp_modeler.lv2/*.ttl \
+ -t "$pkgdir"/usr/lib/lv2/neural_amp_modeler.lv2
+ install -vDm 755 $_pkgname-build/neural_amp_modeler.lv2/*.so \
+ -t "$pkgdir"/usr/lib/lv2/neural_amp_modeler.lv2
+ install -vDm 644 $_pkgname/README.md \
+ -t "$pkgdir"/usr/share/doc/$pkgname
}