summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5567b8b7cc52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = newick-utils
+ pkgdesc = The Newick Utilities are a suite of Unix shell tools for processing phylogenetic trees. Functions include re-rooting, extracting subtrees, trimming, pruning, condensing, drawing (ASCII graphics or SVG).
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = http://cegg.unige.ch/newick_utils
+ arch = any
+ license = BSD
+ makedepends = automake
+ makedepends = autoconf
+ depends = libxml2
+ optdepends = guile
+ source = http://cegg.unige.ch/pub/newick-utils-1.5.0.tar.gz
+ md5sums = 5f65b0fe30bf9389297616358f01fac7
+
+pkgname = newick-utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..984bca067028
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=newick-utils
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="The Newick Utilities are a suite of Unix shell tools for processing phylogenetic trees. Functions include re-rooting, extracting subtrees, trimming, pruning, condensing, drawing (ASCII graphics or SVG)."
+arch=('any')
+url="http://cegg.unige.ch/newick_utils"
+license=('BSD')
+groups=()
+depends=('libxml2' )
+makedepends=('automake' 'autoconf')
+optdepends=('guile')
+source=(http://cegg.unige.ch/pub/$pkgname-$pkgver.tar.gz)
+md5sums=('5f65b0fe30bf9389297616358f01fac7')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make install DESTDIR=$pkgdir
+}