summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 635382693fd6..38fe0f544c22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = nextinspace-git
pkgdesc = Print upcoming space-related events to your terminal
- pkgver = 2.0.3.r0.g846056c
+ pkgver = 2.0.5.r0.g41f21dd
pkgrel = 1
- url = https://github.com/not-stirred/nextinspace
+ url = https://github.com/gideonshaked/nextinspace
arch = any
license = GPL3
makedepends = git
- makedepends = python-setuptools
- makedepends = python-dephell
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-poetry
depends = python-colorama>=0.4.3
depends = python-requests>=2.24
- depends = python-tzlocal
provides = nextinspace
conflicts = nextinspace
- source = nextinspace::git+https://github.com/not-stirred/nextinspace.git
+ source = nextinspace::git+https://github.com/gideonshaked/nextinspace.git
sha256sums = SKIP
pkgname = nextinspace-git
diff --git a/PKGBUILD b/PKGBUILD
index 22a91ac1c1ba..e1b7b5026258 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
_pkgname='nextinspace'
pkgname="${_pkgname}-git"
-pkgver=2.0.3.r0.g846056c
+pkgver=2.0.5.r0.g41f21dd
pkgrel=1
pkgdesc='Print upcoming space-related events to your terminal'
arch=('any')
-url='https://github.com/not-stirred/nextinspace'
+url='https://github.com/gideonshaked/nextinspace'
_url_pypi='https://pypi.org/project/nextinspace'
license=('GPL3')
-depends=('python-colorama>=0.4.3' 'python-requests>=2.24' 'python-tzlocal')
-makedepends=('git' 'python-setuptools' 'python-dephell')
+depends=('python-colorama>=0.4.3' 'python-requests>=2.24')
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel' 'python-poetry')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("${_pkgname}::git+${url}.git")
@@ -21,18 +21,13 @@ pkgver() {
git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "${_pkgname}"
- dephell deps convert --from pyproject.toml --to setup.py
-}
-
build() {
cd "${_pkgname}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${_pkgname}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${_pkgname}"
}