summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2c063d29157
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = nexttool-svn
+ pkgdesc = Communication tool for the LEGO Mindstorms NXT programmable brick
+ pkgver = r654
+ pkgrel = 1
+ url = http://bricxcc.sourceforge.net/utilities.html
+ arch = i686
+ arch = x86_64
+ license = MPL
+ makedepends = subversion
+ makedepends = fpc
+ depends = libusb-compat
+ provides = nexttool
+ source = svn+https://svn.code.sf.net/p/bricxcc/code/
+ md5sums = SKIP
+
+pkgname = nexttool-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47200fde83bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Clemens Brunner <clemens dot brunner at gmail dot com>
+pkgname=nexttool-svn
+pkgver=r654
+pkgrel=1
+pkgdesc="Communication tool for the LEGO Mindstorms NXT programmable brick"
+arch=('i686' 'x86_64')
+url="http://bricxcc.sourceforge.net/utilities.html"
+license=('MPL')
+groups=()
+depends=('libusb-compat')
+makedepends=('subversion' 'fpc')
+provides=('nexttool')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=('svn+https://svn.code.sf.net/p/bricxcc/code/')
+noextract=()
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir/code"
+ printf "r%s" "$(svnversion | tr -d 'A-z')"
+}
+
+build() {
+ cd "$srcdir/code"
+ make -f nexttool.mak
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ cp "$srcdir/code/nexttool" "$pkgdir/usr/bin"
+}