summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e1600e08cf9..8fff732200f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,9 +5,12 @@ pkgbase = nginx-mod-ct
url = https://github.com/grahamedgecombe/nginx-ct
arch = x86_64
license = ISC
- depends = nginx=1.12.2
- source = https://nginx.org/download/nginx-1.12.2.tar.gz
+ depends = nginx=1.18.0
+ source = https://nginx.org/download/nginx-1.18.0.tar.gz
+ source = https://nginx.org/download/nginx-1.18.0.tar.gz.asc
source = nginx-ct-1.3.2.tar.gz::https://github.com/grahamedgecombe/nginx-ct/archive/v1.3.2.tar.gz
+ validpgpkeys = B0F4253373F8F6F510D42178520A9993A1C052F8
+ sha256sums = 4c373e7ab5bf91d34a4f11a0c9496561061ba5eee6020db272a17a7228d35f99
sha256sums = SKIP
sha256sums = b4ceae549b9dbf84b2e511633982e4efeee0388e3b7a038a8bac555008a77b88
diff --git a/PKGBUILD b/PKGBUILD
index 4facaca6e387..4db615d86522 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: Haruue Icymoon <i@haruue.moe>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Haruue Icymoon <i@haruue.moe>
pkgname=nginx-mod-ct
pkgver=1.3.2
pkgrel=1
-_nginxver=1.12.2
+_nginxver=1.18.0
pkgdesc='Nginx module that provides Certificate Transparency supports'
arch=('x86_64')
@@ -13,11 +14,17 @@ url="https://github.com/grahamedgecombe/nginx-ct"
license=('ISC')
source=(
- https://nginx.org/download/nginx-$_nginxver.tar.gz
+ "https://nginx.org/download/nginx-$_nginxver.tar.gz"{,.asc}
"nginx-ct-$pkgver.tar.gz"::"https://github.com/grahamedgecombe/nginx-ct/archive/v$pkgver.tar.gz"
)
-sha256sums=('SKIP'
-'b4ceae549b9dbf84b2e511633982e4efeee0388e3b7a038a8bac555008a77b88')
+
+validpgpkeys=(
+ 'B0F4253373F8F6F510D42178520A9993A1C052F8' # Maxim Dounin <mdounin@mdounin.ru>
+)
+
+sha256sums=('4c373e7ab5bf91d34a4f11a0c9496561061ba5eee6020db272a17a7228d35f99'
+ 'SKIP'
+ 'b4ceae549b9dbf84b2e511633982e4efeee0388e3b7a038a8bac555008a77b88')
build() {
cd "$srcdir"/nginx-$_nginxver