summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a13eb868514..afc31322e79f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
pkgbase = nginx-mod-upstream-fair
pkgdesc = Fair load balancer module for nginx
pkgver = 0.1.3
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/itoffshore/nginx-upstream-fair
arch = x86_64
license = unknown
- depends = nginx=1.16.1
+ makedepends = nginx-src
+ depends = nginx=1.18.0
depends = libutil-linux
- source = https://nginx.org/download/nginx-1.16.1.tar.gz
- source = https://nginx.org/download/nginx-1.16.1.tar.gz.asc
source = nginx-mod-upstream-fair-0.1.3::https://github.com/itoffshore/nginx-upstream-fair/archive/0.1.3.tar.gz
- validpgpkeys = B0F4253373F8F6F510D42178520A9993A1C052F8
- sha256sums = f11c2a6dd1d3515736f0324857957db2de98be862461b5a542a3ac6188dbe32b
- sha256sums = SKIP
sha256sums = 5545e2f2a27d008690a2c60b90c0bf8a997310930d93fca80ebd33dc308ac2fc
pkgname = nginx-mod-upstream-fair
diff --git a/PKGBUILD b/PKGBUILD
index dc29874a05b8..0a822692b06f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,19 @@
pkgname=nginx-mod-upstream-fair
pkgver=0.1.3
-pkgrel=5
+pkgrel=6
_dirname="nginx-upstream-fair-$pkgver"
-_nginxver=1.16.1
+_nginxver=1.18.0
pkgdesc='Fair load balancer module for nginx'
arch=('x86_64')
depends=("nginx=$_nginxver" "libutil-linux")
+makedepends=("nginx-src")
url='https://github.com/itoffshore/nginx-upstream-fair'
license=('unknown')
-source=(
- https://nginx.org/download/nginx-$_nginxver.tar.gz{,.asc}
- "$pkgname-$pkgver::https://github.com/itoffshore/nginx-upstream-fair/archive/$pkgver.tar.gz"
-)
-validpgpkeys=(B0F4253373F8F6F510D42178520A9993A1C052F8) # Maxim Dounin <mdounin@mdounin.ru>
-sha256sums=('f11c2a6dd1d3515736f0324857957db2de98be862461b5a542a3ac6188dbe32b'
- 'SKIP'
- '5545e2f2a27d008690a2c60b90c0bf8a997310930d93fca80ebd33dc308ac2fc')
+source=("$pkgname-$pkgver::https://github.com/itoffshore/nginx-upstream-fair/archive/$pkgver.tar.gz")
+sha256sums=('5545e2f2a27d008690a2c60b90c0bf8a997310930d93fca80ebd33dc308ac2fc')
prepare() {
cd "$srcdir/$_dirname"
@@ -34,13 +29,14 @@ prepare() {
}
build() {
- cd "$srcdir"/nginx-$_nginxver
+ cp -r /usr/src/nginx .
+ cd "$srcdir"/nginx
./configure --with-compat --add-dynamic-module="../$_dirname"
make modules
}
package() {
- cd "$srcdir"/nginx-$_nginxver/objs
+ cd "$srcdir"/nginx/objs
for mod in ngx_*.so; do
install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
done