summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36d3d1156076..6936f5663ddb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nheko-git
pkgdesc = Desktop client for the Matrix protocol
- pkgver = 0.1.0.e78e43c86a39
+ pkgver = 0.1.0.r174.c428ef4b
pkgrel = 1
url = https://github.com/mujx/nheko
arch = i686
@@ -12,7 +12,9 @@ pkgbase = nheko-git
makedepends = fontconfig
makedepends = qt5-tools
depends = qt5-base
- source = nheko-git::git+https://github.com/mujx/nheko.git
+ depends = lmdb
+ source = git://github.com/mujx/nheko.git
+ source = git://github.com/bendiken/lmdbxx.git
md5sums = SKIP
pkgname = nheko-git
diff --git a/PKGBUILD b/PKGBUILD
index 065b0770beb8..6ab61e0060fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,31 @@
# Maintainer: Konstantinos Sideris <siderisk at auth dot gr>
pkgname=nheko-git
-pkgver=0.1.0.e78e43c86a39
+pkgver=0.1.0.r174.c428ef4b
pkgrel=1
pkgdesc="Desktop client for the Matrix protocol"
-arch=('i686' 'x86_64')
+arch=("i686" "x86_64")
url="https://github.com/mujx/nheko"
-license=('GPL3')
+license=("GPL3")
-depends=('qt5-base')
-makedepends=('git' 'cmake' 'gcc' 'fontconfig' 'qt5-tools')
+depends=("qt5-base" "lmdb")
+makedepends=("git" "cmake" "gcc" "fontconfig" "qt5-tools")
-source=($pkgname::git+https://github.com/mujx/nheko.git)
-md5sums=('SKIP')
+source=("git://github.com/mujx/nheko.git"
+ "git://github.com/bendiken/lmdbxx.git")
+md5sums=("SKIP")
+
+prepare() {
+ cd nheko
+ git submodule init
+ git config submodule.lmdbxx.url $srcdir/libs/lmdbxx
+ git submodule update
+}
pkgver() {
cd "$pkgname"
- printf "0.1.0.%s" "$(git rev-parse --short HEAD)"
+ printf "0.1.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {