summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD24
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1cc6ec526bbc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun May 1 06:25:51 UTC 2016
+pkgbase = nodejs-ipscend
+ pkgdesc = Quick and simple deploy tool to host Native Web Applications and Static Web Pages in IPFS
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/diasdavid/ipscend
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ noextract = ipscend-0.2.0.tgz
+ source = http://registry.npmjs.org/ipscend/-/ipscend-0.2.0.tgz
+ sha1sums = b7015df9c3ba759a79f6439a670d5c460377047d
+
+pkgname = nodejs-ipscend
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..990655d4c855
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.tar.gz
+*.tar.xz
+*.tgz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef3c21245d01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Lauri Niskanen <ape@ape3000.com>
+
+_npmname=ipscend
+pkgname=nodejs-ipscend
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Quick and simple deploy tool to host Native Web Applications and Static Web Pages in IPFS"
+arch=(any)
+url="https://github.com/diasdavid/ipscend"
+license=(MIT)
+depends=('nodejs')
+makedepends=('npm')
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
+noextract=($_npmname-$pkgver.tgz)
+sha1sums=('b7015df9c3ba759a79f6439a670d5c460377047d')
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+}