summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5976109ecaba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nodejs-rollup-watch
+ pkgdesc = Watch files for changes and perform incremental rebuilds with Rollup
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = https://github.com/rollup/rollup-watch
+ arch = any
+ license = MIT
+ depends = npm
+ noextract = rollup-watch-4.0.0.tgz
+ source = http://registry.npmjs.org/rollup-watch/-/rollup-watch-4.0.0.tgz
+ sha256sums = 736772714eccfc264181faefd736de4f5447d5cf0e1d9df2623a82e4ce625ea5
+
+pkgname = nodejs-rollup-watch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26059f732c0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+_npmname=rollup-watch
+pkgname=nodejs-$_npmname
+pkgver=4.0.0
+pkgrel=1
+pkgdesc="Watch files for changes and perform incremental rebuilds with Rollup"
+arch=(any)
+url="https://github.com/rollup/rollup-watch"
+license=('MIT')
+depends=('npm')
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
+noextract=($_npmname-$pkgver.tgz)
+sha256sums=('736772714eccfc264181faefd736de4f5447d5cf0e1d9df2623a82e4ce625ea5')
+
+package() {
+ npm install -g --user root --prefix "$pkgdir/usr" "$srcdir/$_npmname-$pkgver.tgz"
+ chmod -R go-w "$pkgdir"/usr
+}