summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD36
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..570fbb6ad1f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = notepadqq-ote-git
+ pkgdesc = Notepad++-like editor for the Linux desktop w/ OTE backend
+ pkgver = 0.52.1.r631.gbfbdf7c
+ pkgrel = 1
+ url = https://github.com/JuBan1/notepadqq
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = uchardet
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
+ optdepends = nodejs: Extensions support (experimental)
+ provides = notepadqq
+ conflicts = notepadqq
+ conflicts = notepadqq-legacy
+ conflicts = notepadqq-git
+ options = !emptydirs
+ source = git+https://github.com/JuBan1/notepadqq.git
+ sha1sums = SKIP
+
+pkgname = notepadqq-ote-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b18a3287960
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+#Maintainer: jakyote <jakkyote - gmail>
+
+pkgname=notepadqq-ote-git
+_pkgname=notepadqq
+pkgver=0.52.1.r631.gbfbdf7c
+pkgrel=1
+pkgdesc="Notepad++-like editor for the Linux desktop w/ OTE backend"
+arch=('x86_64')
+url="https://github.com/JuBan1/notepadqq"
+license=('GPL3')
+depends=('qt5-base' 'uchardet' 'hicolor-icon-theme' 'desktop-file-utils')
+optdepends=('nodejs: Extensions support (experimental)')
+makedepends=('git' 'qt5-tools')
+provides=('notepadqq')
+conflicts=('notepadqq' 'notepadqq-legacy' 'notepadqq-git')
+options=('!emptydirs')
+source=("git+https://github.com/JuBan1/notepadqq.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ set -o pipefail
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_pkgname}"
+ ./configure --prefix /usr
+ make
+}
+
+package() {
+ cd "${_pkgname}"
+ make INSTALL_ROOT="${pkgdir}" install
+}