summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO79
-rw-r--r--PKGBUILD106
-rw-r--r--nova-api.service9
-rw-r--r--nova-cert.service9
-rw-r--r--nova-compute.conf7
-rw-r--r--nova-compute.service10
-rw-r--r--nova-conductor.service9
-rw-r--r--nova-consoleauth.service9
-rw-r--r--nova-novncproxy.service9
-rw-r--r--nova-scheduler.service9
-rw-r--r--nova.install23
-rw-r--r--nova_sudoers3
12 files changed, 282 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d03b61d296e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,79 @@
+pkgbase = nova-icehouse
+ pkgdesc = OpenStack cloud computing fabric controller
+ pkgver = 2014.1.3
+ pkgrel = 1
+ url = https://launchpad.net/nova
+ install = nova.install
+ arch = any
+ license = custom
+ makedepends = python2-setuptools
+ depends = python2-pbr>=0.6
+ depends = python2-pbr<1.0
+ depends = python2-sqlalchemy>=0.7.8
+ depends = python2-sqlalchemy<0.9.99
+ depends = python2-amqplib>=0.6.1
+ depends = python2-anyjson>=0.3.3
+ depends = python2-argparse
+ depends = python2-boto>=2.12.0
+ depends = python2-eventlet>=0.13.0
+ depends = python2-jinja
+ depends = python2-kombu>=2.4.8
+ depends = python2-lxml>=2.3
+ depends = python2-routes>=1.12.3
+ depends = python2-webob>=1.2.3
+ depends = python2-greenlet>=0.3.2
+ depends = python2-paste-deploy>=1.5.0
+ depends = python2-paste
+ depends = python2-migrate-icehouse>=0.8.2
+ depends = python2-netaddr>=0.7.6
+ depends = python2-suds>=0.4
+ depends = python2-paramiko>=1.9.0
+ depends = python2-pyasn1
+ depends = python2-babel>=1.3
+ depends = python2-iso8601>=0.1.9
+ depends = python2-jsonschema>=2.0.0
+ depends = python2-jsonschema<3.0.0
+ depends = python2-cinderclient>=1.0.6
+ depends = python2-neutronclient>=2.3.4
+ depends = python2-neutronclient<3.0
+ depends = python2-glanceclient-openstack>=0.9.0
+ depends = python2-keystoneclient>=0.7.0
+ depends = python2-six>=1.6.0
+ depends = python2-stevedore>=0.14
+ depends = websockify-openstack>=0.5.1
+ depends = websockify-openstack<0.6
+ depends = python2-wsgiref>=0.1.2
+ depends = python2-oslo-config>=1.2.0
+ depends = python2-oslo-rootwrap
+ depends = python2-pycadf>=0.4.1
+ depends = python2-oslo-messaging>=1.3.0
+ depends = python2-carrot
+ depends = python2-cheetah
+ depends = python2-daemon
+ depends = python2-feedparser
+ depends = python2-gflags
+ depends = python2-lockfile
+ depends = python2-novaclient
+ source = https://launchpad.net/nova/icehouse/2014.1.3/+download/nova-2014.1.3.tar.gz
+ source = nova-api.service
+ source = nova-cert.service
+ source = nova-conductor.service
+ source = nova-consoleauth.service
+ source = nova-novncproxy.service
+ source = nova-scheduler.service
+ source = nova_sudoers
+ source = nova-compute.conf
+ source = nova-compute.service
+ md5sums = 5f17b2d997371a56f82d05c2bab4954a
+ md5sums = 8e400161328001ff89cc7ea59a84cfe2
+ md5sums = 6e11f7245b10e39ed024a512108ae95c
+ md5sums = 5e8770c7b964fc82dbb6758688088ad9
+ md5sums = ffd28c32938c99232a8a3de5ab95f6d5
+ md5sums = 52d6eadb4150289497b44a82552bfab0
+ md5sums = 390100b8adaf92df13f660cc451b2f01
+ md5sums = b166058b5c25d0d7851adf30c2356691
+ md5sums = c15ecc2982a90c2a86c110833c6c4bbc
+ md5sums = e16fbaef08ba9fc08a726425d0c79429
+
+pkgname = nova-icehouse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e37747d349b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,106 @@
+# Maintainer: Erhan SAHIN <erhan@ssahin.net>
+
+pkgname=nova-icehouse
+_pkgname=nova
+_relname=icehouse
+pkgver=2014.1.3
+pkgrel=1
+pkgdesc="OpenStack cloud computing fabric controller"
+arch=(any)
+install=nova.install
+url=https://launchpad.net/nova
+license=(custom)
+depends=('python2-pbr>=0.6'
+ 'python2-pbr<1.0'
+ 'python2-sqlalchemy>=0.7.8'
+ 'python2-sqlalchemy<0.9.99'
+ 'python2-amqplib>=0.6.1'
+ 'python2-anyjson>=0.3.3'
+ 'python2-argparse'
+ 'python2-boto>=2.12.0'
+ 'python2-eventlet>=0.13.0'
+ 'python2-jinja'
+ 'python2-kombu>=2.4.8'
+ 'python2-lxml>=2.3'
+ 'python2-routes>=1.12.3'
+ 'python2-webob>=1.2.3'
+ 'python2-greenlet>=0.3.2'
+ 'python2-paste-deploy>=1.5.0'
+ 'python2-paste'
+ 'python2-migrate-icehouse>=0.8.2'
+ 'python2-netaddr>=0.7.6'
+ 'python2-suds>=0.4'
+ 'python2-paramiko>=1.9.0'
+ 'python2-pyasn1'
+ 'python2-babel>=1.3'
+ 'python2-iso8601>=0.1.9'
+ 'python2-jsonschema>=2.0.0'
+ 'python2-jsonschema<3.0.0'
+ 'python2-cinderclient>=1.0.6'
+ 'python2-neutronclient>=2.3.4'
+ 'python2-neutronclient<3.0'
+ 'python2-glanceclient-openstack>=0.9.0'
+ 'python2-keystoneclient>=0.7.0'
+ 'python2-six>=1.6.0'
+ 'python2-stevedore>=0.14'
+ 'websockify-openstack>=0.5.1'
+ 'websockify-openstack<0.6'
+ 'python2-wsgiref>=0.1.2'
+ 'python2-oslo-config>=1.2.0'
+ 'python2-oslo-rootwrap'
+ 'python2-pycadf>=0.4.1'
+ 'python2-oslo-messaging>=1.3.0'
+ 'python2-carrot'
+ 'python2-cheetah'
+ 'python2-daemon'
+ 'python2-feedparser'
+ 'python2-gflags'
+ 'python2-lockfile'
+ 'python2-novaclient')
+makedepends=(python2-setuptools)
+source=("https://launchpad.net/nova/$_relname/$pkgver/+download/$_pkgname-$pkgver.tar.gz"
+ "nova-api.service"
+ "nova-cert.service"
+ "nova-conductor.service"
+ "nova-consoleauth.service"
+ "nova-novncproxy.service"
+ "nova-scheduler.service"
+ "nova_sudoers"
+ "nova-compute.conf"
+ "nova-compute.service")
+md5sums=('5f17b2d997371a56f82d05c2bab4954a'
+ '8e400161328001ff89cc7ea59a84cfe2'
+ '6e11f7245b10e39ed024a512108ae95c'
+ '5e8770c7b964fc82dbb6758688088ad9'
+ 'ffd28c32938c99232a8a3de5ab95f6d5'
+ '52d6eadb4150289497b44a82552bfab0'
+ '390100b8adaf92df13f660cc451b2f01'
+ 'b166058b5c25d0d7851adf30c2356691'
+ 'c15ecc2982a90c2a86c110833c6c4bbc'
+ 'e16fbaef08ba9fc08a726425d0c79429')
+
+build() {
+ cd ${_pkgname}-${pkgver}/
+ python2 setup.py build
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}/
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+
+ install -d "${pkgdir}"/etc/
+ cp -r etc/ "${pkgdir}"/
+ install -d -m 0750 "${pkgdir}"/etc/sudoers.d/
+ cp ${srcdir}/nova_sudoers "${pkgdir}"/etc/sudoers.d/nova_sudoers
+ cp ${srcdir}/nova-compute.conf "${pkgdir}"/etc/nova/nova-compute.conf
+ install -d -m 0770 ${pkgdir}/var/lib/nova/
+ install -d -m 0770 ${pkgdir}/var/log/nova/
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${_pkgname}/LICENSE
+ install -D -m 644 ${srcdir}/nova-api.service ${pkgdir}/usr/lib/systemd/system/nova-api.service
+ install -D -m 644 ${srcdir}/nova-cert.service ${pkgdir}/usr/lib/systemd/system/nova-cert.service
+ install -D -m 644 ${srcdir}/nova-conductor.service ${pkgdir}/usr/lib/systemd/system/nova-conductor.service
+ install -D -m 644 ${srcdir}/nova-consoleauth.service ${pkgdir}/usr/lib/systemd/system/nova-consoleauth.service
+ install -D -m 644 ${srcdir}/nova-novncproxy.service ${pkgdir}/usr/lib/systemd/system/nova-novncproxy.service
+ install -D -m 644 ${srcdir}/nova-scheduler.service ${pkgdir}/usr/lib/systemd/system/nova-scheduler.service
+ install -D -m 644 ${srcdir}/nova-compute.service ${pkgdir}/usr/lib/systemd/system/nova-compute.service
+}
diff --git a/nova-api.service b/nova-api.service
new file mode 100644
index 000000000000..8d89dffcf31e
--- /dev/null
+++ b/nova-api.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Nova API server
+
+[Service]
+ExecStart=/usr/bin/nova-api --config-dir /etc/nova/
+User=nova
+
+[Install]
+WantedBy=multi-user.target
diff --git a/nova-cert.service b/nova-cert.service
new file mode 100644
index 000000000000..060684d5add9
--- /dev/null
+++ b/nova-cert.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Nova Cert server
+
+[Service]
+ExecStart=/usr/bin/nova-cert --config-dir /etc/nova/
+User=nova
+
+[Install]
+WantedBy=multi-user.target
diff --git a/nova-compute.conf b/nova-compute.conf
new file mode 100644
index 000000000000..323047d201a7
--- /dev/null
+++ b/nova-compute.conf
@@ -0,0 +1,7 @@
+[DEFAULT]
+libvirt_type=qemu
+libvirt_ovs_bridge=br-int
+libvirt_vif_type=ethernet
+libvirt_vif_driver=nova.virt.libvirt.vif.LibvirtHybridOVSBridgeDriver
+libvirt_use_virtio_for_bridges=True
+
diff --git a/nova-compute.service b/nova-compute.service
new file mode 100644
index 000000000000..f8f9d408996c
--- /dev/null
+++ b/nova-compute.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Nova Compute server
+
+[Service]
+ExecStart=/usr/bin/nova-compute --config-file /etc/nova/nova.conf --config-file /etc/nova/nova-compute.conf
+User=root
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/nova-conductor.service b/nova-conductor.service
new file mode 100644
index 000000000000..ab029ac3fc41
--- /dev/null
+++ b/nova-conductor.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Nova Conductor server
+
+[Service]
+ExecStart=/usr/bin/nova-conductor --config-dir /etc/nova/
+User=nova
+
+[Install]
+WantedBy=multi-user.target
diff --git a/nova-consoleauth.service b/nova-consoleauth.service
new file mode 100644
index 000000000000..89dbc9d4ede8
--- /dev/null
+++ b/nova-consoleauth.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Nova ConsoleAuth server
+
+[Service]
+ExecStart=/usr/bin/nova-consoleauth --config-dir /etc/nova/
+User=nova
+
+[Install]
+WantedBy=multi-user.target
diff --git a/nova-novncproxy.service b/nova-novncproxy.service
new file mode 100644
index 000000000000..061ab854654e
--- /dev/null
+++ b/nova-novncproxy.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Nova novncproxy server
+
+[Service]
+ExecStart=/usr/bin/nova-novncproxy --config-dir /etc/nova/
+User=nova
+
+[Install]
+WantedBy=multi-user.target
diff --git a/nova-scheduler.service b/nova-scheduler.service
new file mode 100644
index 000000000000..82a521bfb3b5
--- /dev/null
+++ b/nova-scheduler.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Nova Scheduler server
+
+[Service]
+ExecStart=/usr/bin/nova-scheduler --config-dir /etc/nova/
+User=nova
+
+[Install]
+WantedBy=multi-user.target
diff --git a/nova.install b/nova.install
new file mode 100644
index 000000000000..dd83791a139e
--- /dev/null
+++ b/nova.install
@@ -0,0 +1,23 @@
+post_install() {
+ getent group nova &>/dev/null || groupadd nova >/dev/null
+ getent passwd nova &>/dev/null || useradd -d /var/lib/nova -g nova -s /bin/false nova >/dev/null
+
+ chmod 755 /etc/nova
+ chown -R nova:nova /etc/nova
+ chown root:root /etc/nova/rootwrap.conf
+ chown -R root:root /etc/nova/rootwrap.d
+ chown nova:nova /var/lib/nova
+ chown nova /var/log/nova
+ chown root:root /etc/sudoers.d/nova_sudoers
+ chmod 440 /etc/sudoers.d/nova_sudoers
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ getent passwd nova &>/dev/null && userdel nova >/dev/null
+ getent group nova &>/dev/null && groupdel nova >/dev/null
+ true
+}
diff --git a/nova_sudoers b/nova_sudoers
new file mode 100644
index 000000000000..0f4362628777
--- /dev/null
+++ b/nova_sudoers
@@ -0,0 +1,3 @@
+Defaults:neutron !requiretty
+
+nova ALL = (root) NOPASSWD: /usr/bin/nova-rootwrap