summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 782795650db6..27bc8974e229 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Feb 4 07:24:11 UTC 2019
+# Tue Dec 3 22:45:05 UTC 2019
pkgbase = nslink
pkgdesc = tty driver and firmware update for Comtrol DeviceMaster, RTS, LT, PRO, 500, UP, RPSH-SI, RPSH, and Serial port Hub console terminal device server
pkgver = 7.35
diff --git a/PKGBUILD b/PKGBUILD
index e53e7d037ac3..6c4a0eef27ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -103,6 +103,9 @@ prepare() {
-i 'install.sh'
test ! -s 'install.sh.Arch' || echo "${}"
+ # Fix /var/run
+ sed -e 's:/var/run/:/run/:g' -i 'nslink.service'
+
# Switch to python2
sed -e '# Why using local on just this one?' \
-e 's:/usr/local/bin/python:/usr/bin/python:g' \
@@ -123,7 +126,10 @@ prepare() {
sed -e 's:^[^#]:#&:g' -i 'nslink.conf'
# Fix makefile
- sed -e 's:=/lib/modules:=/usr/lib/modules:g' -i 'Makefile'
+ sed -e 's:=/lib/modules:=/usr/lib/modules:g' \
+ -e '# Switch SUBDIRS= to M= for Kernel 5.4' \
+ -e 's:SUBDIRS=:M=:g' \
+ -i 'Makefile'
# Correct group and chmod for serial
sed -e '/getgrnam/ s:"tty":"uucp":g' \